Changes between Version 3 and Version 4 of TracInstall


Ignore:
Timestamp:
Feb 11, 2015, 12:43:15 AM (5 years ago)
Author:
trac
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • TracInstall

    v3 v4  
    3838This will download the latest SQLite code and build the bindings. SQLite 2.x is no longer supported.
    3939
    40 A known bug in [trac:PySqlite] versions 2.5.2-4 prohibits upgrades of Trac databases from 0.11.x to 0.12. Please use versions 2.5.5 and newer or 2.5.1 and older. See #9434 for more detail. See additional information in [trac:PySqlite PySqlite].
     40A known bug in [trac:PySqlite] versions 2.5.2-4 prohibits upgrades of Trac databases from 0.11.x to 0.12. Please use versions 2.5.5 and newer or 2.5.1 and older. See [trac:#9434] for more detail. See additional information in [trac:PySqlite PySqlite].
    4141
    4242==== For the PostgreSQL database #ForPostgreSQL
     
    8181   - [http://code.google.com/p/modwsgi/ mod_wsgi], see [wiki:TracModWSGI] and
    8282     http://code.google.com/p/modwsgi/wiki/IntegrationWithTrac
    83    - [http://modpython.org/ mod_python 3.3.1], (deprecated: see TracModPython)
     83   - [http://modpython.org/ mod_python >= 3.3.1], (deprecated: see TracModPython)
    8484 * a [http://www.fastcgi.com/ FastCGI]-capable web server (see TracFastCgi)
    8585 * an [http://tomcat.apache.org/connectors-doc/ajp/ajpv13a.html AJP]-capable web
     
    206206
    207207Using the default database connection string in particular will always work as long as you have SQLite installed.
    208 For the other [DatabaseBackend database backends] you should plan ahead and already have a database ready to use at this point.
     208For the other [trac:DatabaseBackend database backends] you should plan ahead and already have a database ready to use at this point.
    209209
    210210Since 0.12, Trac doesn't ask for a [TracEnvironment#SourceCodeRepository source code repository] anymore when creating an environment. Repositories can be [TracRepositoryAdmin added] afterwards, and support for specific version control systems is disabled by default.