Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#79 closed bug (fixed)

Missing translations...

Reported by: Mikhail Malyshev Owned by: Thore Böckelmann
Priority: normal Milestone: 3.9-2014R2
Component: muimaster.library Version: 3.9-nightly build
Severity: minor Keywords:
Cc: OS Platform: All
Blocked By: Blocking:
Release Notes:

Description

Favourite colours…
red
gren
etc.

Menu/Delay (seconds abbreviation (s) )
Help/Delay (again, seconds)

Attachments (1)

MUI4.png (153.0 KB) - added by Mikhail Malyshev 6 years ago.

Download all attachments as: .zip

Change History (28)

comment:1 Changed 6 years ago by Mikhail Malyshev

also sizes KB, MB …

comment:2 Changed 6 years ago by Mikhail Malyshev

Hz, kHz … (screenmodes)

comment:3 Changed 6 years ago by Mikhail Malyshev

Looking at MUI4/OS4 it does not use all available translations from 3.9 locale.
eg. Prefs/Menues is mostly untranslated (but translations are available)
in fact in many places.

I guess MUI4 will be using it's own translation that is loosely based on 3.9

comment:4 Changed 6 years ago by Thore Böckelmann

Milestone: MUI 3.9-2014R2
Owner: set to Thore Böckelmann
Priority: undecidednormal
Status: newassigned

I will add the missing translations as soon as possible.

Looking at MUI4/OS4 it does not use all available translations from 3.9 locale. eg. Prefs/Menues is mostly untranslated (but translations are available) in fact in many places.

What are you trying to tell here? If the strings can be translated but nobody did a translation so far this is not our fault.

I guess MUI4 will be using it's own translation that is loosely based on 3.9

If you had used transifex to do the russian translation you would have noticed that MUI 3.9 and MUI4 have separate translations. However, if I add something to either of both which is used in the other one as well I will merge the changes to let both systems benefit of the new translatable strings.

comment:5 Changed 6 years ago by Mikhail Malyshev

That exactly what I was talking about, it's odd to see translations in v39 branch that are obviously from v40 but at the same time if you feed the v39 catalog to v40 you find out that a lot of the translations that are available are not actually used by v40 and require a separate translation.
Was not it simple enough to keep the catalogs unified and just add a few new strings required for v40? It's really odd for MUI to break the catalog structure with each revision, it's not the way the lccale system was designed. It should be compatible to previous versions and only new strings missing if there were any addition. And at the same time a newer catalog could be used with previous versions too. I know we can't do anything about it now, but maybe the v39/v40 branches can be unified ?

comment:6 Changed 6 years ago by Thore Böckelmann

In 3825:

Merged revision(s) 3824 from trunk/mui4x:

  • Dirlist.c: made the size unit names translatable. This refs #79.

……..

comment:7 Changed 6 years ago by Thore Böckelmann

Resolution: fixed
Status: assignedclosed

In 3826:

  • Pubscreenadjust.c, Settingsgroup.c: made the frequency and time strings translatable. This closes #79.

comment:8 in reply to:  5 Changed 6 years ago by Jens Maus

Replying to Michael:

That exactly what I was talking about, it's odd to see translations in v39 branch that are obviously from v40 but at the same time if you feed the v39 catalog to v40 you find out that a lot of the translations that are available are not actually used by v40 and require a separate translation.
Was not it simple enough to keep the catalogs unified and just add a few new strings required for v40? It's really odd for MUI to break the catalog structure with each revision, it's not the way the lccale system was designed. It should be compatible to previous versions and only new strings missing if there were any addition. And at the same time a newer catalog could be used with previous versions too. I know we can't do anything about it now, but maybe the v39/v40 branches can be unified ?

I am sorry Michael, but are you an AmigaOS developer or Thore and me? So how do you think you know how the locale system was designed? In fact, it is perfectly valid what we are doing and there is no reason to keep backward compatibility in catalogs under all circumstances. So please don't argue with us how we should deal with catalogs since we know best about it. And in fact, I don't see a reason why we should keep backward compatibility in catalog files and keep old and obsolete strings in catalogs which are obviously only used by newer catalog generation. So, please, before arguing about catalogs with us you should better finish your promised russian translation of YAM.

comment:9 Changed 6 years ago by Mikhail Malyshev

I have completed current MUI39, just a few bits left to tidy up.
Shame that MUI40 is different, that's what I was trying to say.
It seems to work with 39 catalog too, but does not reuse a lot of strings that were already translated and that's disappointing.

As for version to version compatibility it is nice to have it if nothing major has changed, it simplifies a lot of things, especially if someone is trying out different versions of the software, which in our case requires complete clean up of everything, or it will break. It might not relate much to MUI or YAM, as they are very complicated things, but a lot of smaller things suffer from it too, eg. mcc classes.

As for YAM, it will be finished sometime, but since I have problems building and checking it at the moment, it has been put on hold until a reasonable solution is found or I have a lot more time to struggle with what we have. (The last translation you have is actually more or less full (only some warnings and help is missing, that a general user will not see mostly)

comment:10 in reply to:  9 Changed 6 years ago by Jens Maus

Replying to Michael:

I have completed current MUI39, just a few bits left to tidy up.
Shame that MUI40 is different, that's what I was trying to say.
It seems to work with 39 catalog too, but does not reuse a lot of strings that were already translated and that's disappointing.

That's exactly why we already proposed to you a hundreds times to use transifex since it provides mechanisms and help to copy&paste already translated strings to a new project. Using an editor and converting back- and forth between .po and .ct format is no proper solution anymore. And in fact, we won't accept any submission of .ct files anymore. So if you translate something (MUI or YAM) use transifex or provide UTF8-encoded .po file which we can upload to transifex. If you cannot deal with that I am sorry to say but there are other russian speaking people around which don't have a problem with transifex and the po file format.

comment:11 in reply to:  9 Changed 6 years ago by Thore Böckelmann

Replying to Michael:

Shame that MUI40 is different, that's what I was trying to say.
It seems to work with 39 catalog too, but does not reuse a lot of strings that were already translated and that's disappointing.

Believe it or not, but any application using locale.library does work without any translation at all and just with the built-in strings. It is no secret that any translation, no matter how complete or incomplete it may be, will work as long as the application is not demanding anything very special.

As for version to version compatibility it is nice to have it if nothing major has changed, it simplifies a lot of things, especially if someone is trying out different versions of the software, which in our case requires complete clean up of everything, or it will break. It might not relate much to MUI or YAM, as they are very complicated things, but a lot of smaller things suffer from it too, eg. mcc classes.

On AmigaOS3 there is no choice between MUI3 and MUI4. You only have MUI 3.8/3.9 there. So why are you trying to mix up MUI3 and MUI4 here?

comment:12 Changed 6 years ago by Mikhail Malyshev

MUI39/40 both work on a classic system, and 3.8 is totally different from these (as you have pointed out before). If 39 was just an updated 38 it would have been a dream come true for many. For me the best compromise was MUI39 (2005 version) for the classic 68K systems.
And again you are missing the main points… I guess I simply can not explain it well to you since we think different.

comment:13 Changed 6 years ago by Thore Böckelmann

Software development is about pushing a software forward, not to keep it where it already is. The latter is called "stangancy" or "standstill". If you like the old version better then stick with it.

And which version of MUI4 runs on a classic system?

comment:14 Changed 6 years ago by Mikhail Malyshev

Pushing forward, yes, and it's the key, but not forcing things and by not dropping perfectly working options that worked before, keep them, offer new advanced things, they are great, just leave the user to decide if he/she/it needs or wants to use it.

It's odd when you bring some advanced things to MUI39 and then say simpler things like font requester are for MUI4, or a setting for tinting the loaded background image.

eg. The colour requester already has a choice of different colour picker gadgets,
why not add/return a simpler one there too.

Give the user more control of how the file list requester works (eg. add .info filter button) add snooping/rendering/cache settings for preview view mode etc.

Sorry for being a bit wordy, and I hope I don't have to copy this to every other related ticket or start a new one unless you insist on it. And everything has to be nice and tidy in it's own place even if it is related to each other.

comment:15 Changed 6 years ago by Mikhail Malyshev

Missing: About → Support: (www.sas….)

comment:16 Changed 6 years ago by Mikhail Malyshev

Beta messages, warnings, expire date ?

comment:17 Changed 6 years ago by Mikhail Malyshev

How to easily diff changes in po files against a pot?
Previously FlexCat had this option for cd/ct, now it's a hand job.

comment:18 Changed 6 years ago by Mikhail Malyshev

Favourite colour names in pop up menu are still in english

comment:19 Changed 6 years ago by Mikhail Malyshev

R G B, H S V
should be in translation too

Changed 6 years ago by Mikhail Malyshev

Attachment: MUI4.png added

comment:20 Changed 6 years ago by Mikhail Malyshev


MUI4 on my classic miggy, using translation from 39.
As you can see it is partially translated
(eg. Font) you would expect it to be translated if it was already below.

Ok. How do we merge 39 with 40 po, there is no update/add feature in FlexCat ?
Complete rework by hand ?

comment:21 in reply to:  16 Changed 6 years ago by Thore Böckelmann

Replying to Michael:

Beta messages, warnings, expire date ?

These will not be made translatable. First of all because these messages appear before the catalog is even loaded. And second they will not be contained in the normal release version.

comment:22 in reply to:  17 Changed 6 years ago by Thore Böckelmann

Replying to Michael:

How to easily diff changes in po files against a pot?
Previously FlexCat had this option for cd/ct, now it's a hand job.

There is no need for this if you use transifex. Furthermore both .pot and .po are self-contained. Any change done to the .pot file will automatically be forwarded to the individual .po files.

comment:23 in reply to:  20 Changed 6 years ago by Thore Böckelmann

Replying to Michael:

Ok. How do we merge 39 with 40 po, there is no update/add feature in FlexCat ?
Complete rework by hand ?

Use transifex. It makes reusing already existing translations very easy. It does not take more than 2 mouse clicks.

comment:24 Changed 6 years ago by Thore Böckelmann

In 3864:

  • Colorring.c: made the favorite color names and RGB/HSV strings translatable. This refs #79.

comment:25 Changed 6 years ago by Thore Böckelmann

In 3865:

* Aboutpage.c: made the "Support" string translatable. This refs #79.

comment:26 in reply to:  24 Changed 6 years ago by Thore Böckelmann

Replying to tboeckel:

In 3864:

  • Colorring.c: made the favorite color names and RGB/HSV strings translatable. This refs #79.

Please note that you need to delete ENV(ARC):MUI/Colors.txt if it exists, because it contains the still untranslated names. Otherwise MUI will continue to use the english names.

comment:27 Changed 6 years ago by Thore Böckelmann

Milestone: MUI 3.9-2014R23.9-2014R2

Milestone renamed

Note: See TracTickets for help on using tickets.