Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#72 closed bug (fixed)

Odyssey: Dragged text not visible in bookmark

Reported by: Samir Hawamdeh Owned by: Thore Böckelmann
Priority: normal Milestone: 4.0-2014R4
Component: List.mui Version: 4.0-nightly build
Severity: minor Keywords:
Cc: OS Platform: AmigaOS4
Blocked By: Blocking:
Release Notes:

Fixed a wrong drag image when dragging URLs from Odyssey's bookmark window.

Description

Summary

If you drag an URL from the bookmark window of Odyssey to the main (Odyssey) window the text of the item dragged is not visible.

The URL will be loaded normally when dragged, but a "white stripe" is always showed instead of a proper visible (link) object

This until you finally release this object into the target window, aka until you release the mouse button into the target

Steps to reproduce

  1. Make sure to have atleast a saved link in your OWB's bookmark
  2. Open the bookmark window of OWB and then try to drag your link into the main window of Odyssey

Expected results

During dragging you should be able to read the name of the link, maybe with a sort of trasparence effect

Actual results

Actuallty during operation you are not able to read any text, instead it will be showed a white stripe instead of a trasparent (or atleast a readable) link

A grab is attached altrough it can't show the behaviour because this problem happen in drag state only

Attachments (1)

draganddrop.png (413.1 KB) - added by Samir Hawamdeh 5 years ago.

Download all attachments as: .zip

Change History (10)

Changed 5 years ago by Samir Hawamdeh

Attachment: draganddrop.png added

comment:1 Changed 5 years ago by Thore Böckelmann

Which nightly build exactly are you referring to? If it is the most recent one (25.7.2014) did this happen with the previous nightly builds, too? Or with the last official release R3?

comment:2 Changed 5 years ago by Samir Hawamdeh

Hi Thore,

Yes it happened in R3 aswell and i think it was the same also in the oldest versions, actually i'm using the nightly SVN-r3700 and i have the same problem.

comment:3 Changed 5 years ago by Thore Böckelmann

Component: undefinedList.mui
Milestone: MUI 4.0-2014R4
Owner: set to Thore Böckelmann
Priority: undecidednormal
Status: newassigned

I can now confirm that this happens for me as well. But this issue depends on the horizontal size of the list. Up to a certain size the drag image is just white, a larger list produces the correct drag image.

comment:4 Changed 5 years ago by Samir Hawamdeh

Yep that's true, tested here aswell and it's ok with a larger size
Never noticied this…

comment:5 Changed 5 years ago by Thore Böckelmann

In 3915:

  • List.c: the default drag image now shows the full contents of a line instead of just the visible part. This refs #72.

comment:6 Changed 5 years ago by Thore Böckelmann

Please check if the latest modification fixes this issue. I cannot tell when I am able to check this myself, not enough spare time :(

comment:7 Changed 5 years ago by Thore Böckelmann

Release Notes: modified (diff)
Resolution: fixed
Status: assignedclosed

I found the time to check this myself and for me the drag image is now always correct, no matter how wide the list is shown. Hence I will close this ticket.

comment:8 Changed 5 years ago by Samir Hawamdeh

Yes confirmed, it's fixed :-)

comment:9 Changed 4 years ago by Thore Böckelmann

Milestone: MUI 4.0-2014R44.0-2014R4

Milestone renamed

Note: See TracTickets for help on using tickets.