Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#64 closed bug (wontfix)

XEN Button Style

Reported by: Mikhail Malyshev Owned by:
Priority: normal Milestone: 3.9-2014R2
Component: Area.mui Version: 3.9-nightly build
Severity: minor Keywords:
Cc: OS Platform: AmigaOS3
Blocked By: Blocking:
Release Notes:

Description

XEN frames have lost their shifted image/text effect

i.e. When it is used for a button, and that button is pressed, it's content got shifted 1 pxl down and to the right.

Please return this one of the most wonderful feature!

Attachments (1)

RIP-MUI-AOS3.JPG (81.0 KB) - added by Mikhail Malyshev 6 years ago.
In memory of the classic XEN button style with shifted pressed look…

Download all attachments as: .zip

Change History (13)

comment:1 Changed 6 years ago by Thore Böckelmann

Component: undefinedArea.mui
Milestone: MUI 3.9-2014R2
Priority: undecidednormal
Resolution: wontfix
Status: newclosed

Sorry, but this will not be changed back. The reason is that the visual shift shifted the object's complete coordinate system. Depending on where one clicked a button it could happen that the button stayed pressed after releasing the mouse button, because the release event happened outside the (now shifted) object area and hence the object does not receive the event to be able to handle it.

To make it short, consistency weights more than visual effects.

comment:2 Changed 6 years ago by Mikhail Malyshev

Resolution: wontfix
Status: closedreopened

Woooooooooo……
This was one of the best features and I have never had a problem with it in 20 years.
I am sure something can be done.

Just checked and tried to reproduce the problem, and can confirm that there is
a small problem with left and top 1 pxl line. It does allow the button to be pressed, but it has no effect.

Solution!!!

Keep the old shifted effect, but make the button selection area smaller by 1 pxl
or better said, remove the black border around the button from the mouse selection area.

This way we can keep the looks, shifting and fix the problem.

PS: Other GUIs and patches for GUI's don't seem to have this problem
So if the above solution is not good enough, then it can be done somehow else.
But the effect is MUI and what made it what it is and many other GUI's are based on this.

comment:3 Changed 6 years ago by Thore Böckelmann

Resolution: wontfix
Status: reopenedclosed

Jens already pointed out that we will not create a MUI which fits your personal demands. This "feature" will not be reimplemented, no matter how often you ask for it.

comment:4 Changed 6 years ago by Mikhail Malyshev

You have virtually killed me :(

comment:5 Changed 6 years ago by Thore Böckelmann

We won't reimplement bugs just to please your need for visual effects. You confirmed yourself that the bug exists in MUI 3.8, yet you are demanding to put it back in. Why?

You really have no idea how MUI works internally. MUI cannot exclude "certain" areas from an object for just one special frame setting just to provide a very weak visual feedback. The frame is part of the object's graphical area and MUI does not care a bit how the frame really looks like.

comment:6 Changed 6 years ago by Mikhail Malyshev

So, as far as I have understood, previously something fishy was done to get the shifted effect and that had a potential black hole in top left pixel of the buttons. It did no harm, but formally it was a bug.

If I understand correctly, the standard frame and selected frame are two different frames. If the old MUI dis something odd, why the frame was drawn correctly?
This makes me think that the hole image for that frame was actually drawn incorrect
shifted by 1 pxl to top left, otherwise, with the shifted are the hole image+frame would have moved. So what prevents us from moving the contents of the button by 1 pxl right and 1 down when we draw the selected frame? Even if we reuse the alignment code for the text/image of the button, we can add an offset to that (not to the button structure or what ever was done before)

PS: I have one more crazy idea (!)

comment:7 Changed 6 years ago by Mikhail Malyshev

Any comments ?

comment:8 Changed 6 years ago by Thore Böckelmann

No.

comment:9 Changed 6 years ago by Mikhail Malyshev

Really a shame. GadTools, ReAction got the shifted indenting feel.
Windows and other OS have it everywhere these days.
Sure something can be done with a special setting (like allow button contents shifting). We still have the scroll bar, the image buttons that have this feeling. So the question is only normal buttons. And that is not limited to one frame design only, it can be used with many.

Changed 6 years ago by Mikhail Malyshev

Attachment: RIP-MUI-AOS3.JPG added

In memory of the classic XEN button style with shifted pressed look…

comment:10 Changed 6 years ago by Mikhail Malyshev

In memory of the classic XEN button style with shifted pressed look...
In memory of the classic XEN button style with shifted pressed look…

Ok, things are not that bad really, maybe we can add something to the tweaks page

comment:11 in reply to:  10 Changed 6 years ago by Jens Maus

Replying to Michael:

In memory of the classic XEN button style with shifted pressed look…

Ok, things are not that bad really, maybe we can add something to the tweaks page

To be honest, Thore and me are already at a point now that we actually think about removing your permissions to this site and starting simply to ignore you.

Michael, I know that the russian way of living is unfortunately different to the western world since a while. However, so far I really thought that this offensive nature and attitude was only true for the one dictator that you call your hero. After all these discussions with you and by looking at this particular posting it seems I was wrong as the offensive attitude of you and your not existing willingness to accept things and to compromise seems to be in line what your current leadership thinks is right.

So sorry Michael, but stop this attitude immediately and return to constructive discussions or we will ban and ignore you.

comment:12 Changed 6 years ago by Thore Böckelmann

Milestone: MUI 3.9-2014R23.9-2014R2

Milestone renamed

Note: See TracTickets for help on using tickets.