Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#53 closed bug (invalid)

GLArea

Reported by: Mikhail Malyshev Owned by:
Priority: normal Milestone: 3.9-2014R2
Component: foreign class Version: 3.9-2014R1
Severity: minor Keywords:
Cc: OS Platform: AmigaOS3
Blocked By: Blocking:
Release Notes:

Description

GLArea demo fails to respond to switching objects popup menu and some settings. Works ok on 3.8/early 3.9, also under current 3.9 it is much slower.

Attachments (1)

MUI-GL.PNG (95.8 KB) - added by Mikhail Malyshev 6 years ago.

Download all attachments as: .zip

Change History (8)

Changed 6 years ago by Mikhail Malyshev

Attachment: MUI-GL.PNG added

comment:1 Changed 6 years ago by Thore Böckelmann

What exactly is "early MUI 3.9"? If you are referring to any specific version you should specify the exact version numbers, just to avoid any confusion.

comment:2 Changed 6 years ago by Mikhail Malyshev

Old MUI 3.9 - 2004/2005 builds done by Jens Langner

comment:3 Changed 6 years ago by Thore Böckelmann

Would you care to tell us who leaked these builds? They were never meant to become public.

Anyway, any speed related differences between the current and the old builds will not be handled here.

What else except GLArea.mcc does one need to reproduce this issue? The class alone doesn't seem to be enough.

comment:4 Changed 6 years ago by Mikhail Malyshev

Good news here, the complete source and demo are on Aminet

http://aminet.net/dev/mui/GLArea_src.lha
http://aminet.net/dev/mui/MCC_GLArea_Dev.lha
http://aminet.net/dev/mui/MCC_GLArea_Usr.lha

As for MUI, it came from Jens for beta testing

comment:5 Changed 6 years ago by Thore Böckelmann

The availibility of the source doesn't help much. I took a look at it and the cycle object creation is perfectly ok. For me the cycle's popup menu works for a few times and then eventually opens without any text. Since no other application or class exhibits a similar behaviour I suspect some memory trashing by either the demo application or the GLArea class itself.

comment:6 Changed 6 years ago by Thore Böckelmann

Component: undefinedforeign class
Milestone: MUI 3.9-2014R2
Priority: undecidednormal
Resolution: invalid
Status: newclosed

I investigated a bit more and found out that GLArea.mcc is doing lots of invalid memory accesses, specifically NULL pointers. This is beyond MUI's scope. If you really need this class then go ahead and repair it yourself.

comment:7 Changed 6 years ago by Thore Böckelmann

Milestone: MUI 3.9-2014R23.9-2014R2

Milestone renamed

Note: See TracTickets for help on using tickets.