Opened 6 weeks ago

Closed 6 weeks ago

Last modified 6 weeks ago

#414 closed bug (fixed)

Mui ASL request freezes

Reported by: Eero Owned by: Thore Böckelmann
Priority: normal Milestone: 5.0-2019R3
Component: List.mui Version: 5.0-2019R2
Severity: minor Keywords:
Cc: OS Platform: AmigaOS4
Blocked By: Blocking:
Release Notes:

Description

Any program using ASL request seems to freeze the asl file request if I use the Mui version. Commenting it out from user startup fixed the problem so I can now use the system.

Machine is X1000, OS 4.1 FE with all latest updates.
I tried the request on at least following programs, AmiDVD, Digibooster, Emotion, Filecompare and Notepad.
I have crash logs on many of those I try add here also soon.
the request opens well but if I change the directories a few times it freezes and gives the popup problem report and after choosing kill, it will freeze the whole system. Sometimes it freezes after one volumes button press sometimes it needs moere clicks.

Attachments (6)

Crashlog_Updater_Download_2019-07-13_11-07-25.txt (32.6 KB) - added by Eero 6 weeks ago.
Crashlog
Crashlog_DigiBooster_2019-08-11_14-22-45.txt (35.6 KB) - added by Eero 6 weeks ago.
Crashlog
Crashlog_Emotion_2019-08-11_14-40-52.txt (33.8 KB) - added by Eero 6 weeks ago.
Crashlog
Crashlog_FileCompare_2019-08-11_14-43-06.txt (32.8 KB) - added by Eero 6 weeks ago.
Crashlog
MUI-5.0-20190812r6447-os4-debug.lha (1.2 MB) - added by Thore Böckelmann 6 weeks ago.
Muidebug_crash.log (98.8 KB) - added by Eero 6 weeks ago.
asl crash Notepad log

Download all attachments as: .zip

Change History (9)

Changed 6 weeks ago by Eero

Crashlog

Changed 6 weeks ago by Eero

Crashlog

Changed 6 weeks ago by Eero

Crashlog

Changed 6 weeks ago by Eero

Crashlog

comment:1 Changed 6 weeks ago by Thore Böckelmann

Component: muimaster.libraryList.mui
Milestone: future release5.0-2019R3
Owner: set to Thore Böckelmann
Priority: undecidednormal
Status: newassigned

All crashlogs point to exactly the same location. So far I cannot tell yet what might trigger this bug. So please install the attached debug version of muimaster.library and try to reproduce the crash while capturing a debug log as described in the FAQ. No special settings are required, all I need is the log.

Last edited 6 weeks ago by Thore Böckelmann (previous) (diff)

Changed 6 weeks ago by Thore Böckelmann

comment:2 Changed 6 weeks ago by Thore Böckelmann

Resolution: fixed
Status: assignedclosed

In 6448:

  • List.c: added a check for the active entry to be valid before selecting the corresponding list entry. This closes #414.

comment:3 Changed 6 weeks ago by Eero

Seems that debuging this is not easy. I have not been doing any of that on an Amiga before. I was able to get the Sashami and Memguard there but could not use Memguard since when that was running everything froze at once i had it running. Might be wrong settings.
When I run just the debug version of the library and no Sashami or Memguard I was not able to reproduce the bug. The asl request with extensions sems to work just fine several times opneing closing and clickin away with several programs.
Once I activated the debug output with setenv muidebug all and Sashami then the asl request froze the moment I clicked open on Notepad. That debug I will include here.

This is what I tried on my user-startup. And I had to remove the memguard line to get somewhere without instant crash. Any suggestion what parameters should be used? Both version were from os4depot so they shoudl be correct for os4.

setenv muidebug all
Run >NIL: MemGuard
Run >NIL: Sashimi on noprompt >work:MuiDebug3.log

Ha, you found the reason just as I was writing this…

Changed 6 weeks ago by Eero

Attachment: Muidebug_crash.log added

asl crash Notepad log

Note: See TracTickets for help on using tickets.