Opened 7 months ago

Closed 7 months ago

Last modified 7 months ago

#407 closed bug (wontfix)

IBrowse navigation buttons

Reported by: Mikhail Malyshev Owned by:
Priority: normal Milestone: 5.0-2019R2
Component: undefined Version: 5.0-2019R1
Severity: minor Keywords:
Cc: OS Platform: AmigaOS3
Blocked By: Blocking:
Release Notes:

Description

Summary

Navigation buttons in IBrowse are drawn differently under MUI 5
Not highlighted during selection, backgrounds are not restored
Easy test scenario - AmiKit v8+ in WinUAE (default setup)

Steps to reproduce

  1. Click Home/About or load page
  2. STOP button should appear briefly and disapper

Expected results

under 3.8/3.9 it all worked nicely

Actual results

artifacts, no button highlighting

Regression

Notes

Attachments (1)

MUI5-IB.png (67.4 KB) - added by Mikhail Malyshev 7 months ago.
IB problems even with 100%

Download all attachments as: .zip

Change History (4)

comment:1 Changed 7 months ago by Thore Böckelmann

Milestone: future release5.0-2019R2
Priority: undecidednormal
Resolution: wontfix
Status: newclosed

This effect happens with IBrowse 2.4 only, because the toolbutton class of IB 2.4 draws its own disabled effect instead of leaving this task to MUI. Unfortunately invisible buttons are disabled as well, but not completely hidden. That's why MUI's internal disabled effect is still visible for these buttons.

IBrowse 2.5 already handles this correctly and will no longer draw the disabled effect itself and will no longer disable invisible buttons.

As a workaround you can configure MUI to use the "none" disabled pattern with a visibility of 100% for IBrowse only.

Changed 7 months ago by Mikhail Malyshev

Attachment: MUI5-IB.png added

IB problems even with 100%

comment:2 Changed 7 months ago by Mikhail Malyshev

The proposed solution does not work, see picture
Why MUI5 breaks compatibility? What's the reason behind such changes ?
Chances of us seeing IB 2.5 are so slim that almost everyone has lost hope by now.

comment:3 in reply to:  2 Changed 7 months ago by Thore Böckelmann

Replying to Mikhail Malyshev:

The proposed solution does not work, see picture

This has nothing to do with the disabled effect. IBrowse's toolbutton class simply fails to render the background correctly for invisible buttons.

Why MUI5 breaks compatibility? What's the reason behind such changes ?

This kind of disabled effect has been available for 7 (I repeat: seven) years by now. Please don't tell me this is really news for you. Furthermore MUI now offers a centralized way to get a consistent disabled effect applied to all GUI elements. Before each and every class - internal and external - had to implement and draw this disabled effect itself. The fact that IB 2.4 fails so obviously is more proof that this necessity had to be erased. Every simply button is correctly disabled. It is only IB's toolbuttons as subclass of Area class, which fail to handle the drawing of the background imagery for invisible buttons. For visible buttons everything is done right, as you can see for all buttons. Only the background of the invisible stop button is drawn wrong. And this cannot be fixed in MUI.

Note: See TracTickets for help on using tickets.