Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#30 closed bug (fixed)

Text and graphics problem on dropdown menu of OWB

Reported by: Samir Hawamdeh Owned by: Thore Böckelmann
Priority: normal Milestone: 4.0-2015R1
Component: muimaster.library Version: 4.0-2014R3
Severity: minor Keywords:
Cc: Roman Kargin OS Platform: AmigaOS4
Blocked By: Blocking:
Release Notes:

Description

Not always, but in certain condition the text of the history and even the graphical arrows inside the dropdown menu of OWB will just disappear, this happen mostly if you open manually the dropdown menu clicking on the "arrow" button of the Odyssey GUI

At first step only the text are not showed, but if you try to scroll the list with the mouse wheel then also the arrows will disappear, see grab attached

Attachments (2)

dropdown_issue.png (551.3 KB) - added by Samir Hawamdeh 5 years ago.
Conf.lha (2.9 MB) - added by Samir Hawamdeh 5 years ago.

Change History (18)

Changed 5 years ago by Samir Hawamdeh

Attachment: dropdown_issue.png added

comment:1 Changed 5 years ago by Thore Böckelmann

Can you please provide some better instructions how to reproduce this issue than "not always, but in certain condition"? What exactly are these certain conditions?

comment:2 Changed 5 years ago by Samir Hawamdeh

Well if it was so understandable since beginning I would definitely wrote an appropriate report with all details, aniway i did some more test and i think that problem could be related to the History.db file (Conf/History.db) that step by step will updates itself during navigation ..

As a test I cancelled my History.db file in order to have a completely new History at startup, then i load a web page as a test, finally i (manually) reopen again the dropdown menu of the browser and now the menu content seems fine again, aka no graphical corruption at all ..

I need some more test, however i suspect that this graphical glitch might be caused by the auto-incrementation of this database file.

comment:3 Changed 5 years ago by Thore Böckelmann

If this issue can be triggered by a history.db file with a certain content then please provide such a file as soon as it happens again. I will then try myself to reproduce this issue using that file.

comment:4 Changed 5 years ago by Thore Böckelmann

Component: Calltips.mccList.mui
Priority: undecidednormal

comment:5 Changed 5 years ago by Samir Hawamdeh

Ok i waited a bit more in order to grow up my History.db file, so now i can reproduce the issue on my Amiga.
Infact I noticed that the db file should be enough (as size) to finally be able to reproduce the problem

In attachment i send you my entire "Conf" folder, what you need to do is:

  • Make a backup of you "Conf" folder of Odyssey
  • Copy my "Conf" folder on the same path
  • Start Odyssey opening a new session
  • Now on the search area try to type the letter 'g'

Pressing 'g' should show one of the various www google address stored in db file, however the dropdown menu will show a blank list instead .. you can navigate into them and all the adderess still availible on that list, you can even use the mouse pointer to navigate and choose them from the menu .. however text still invisible and once you play with the graphical arrows of the dropdown menu you will got the graphical glitch i report you in my initial report

Changed 5 years ago by Samir Hawamdeh

Attachment: Conf.lha added

comment:6 Changed 5 years ago by Thore Böckelmann

Component: List.muimuimaster.library
Milestone: MUI 4.0-2014R4
Owner: set to Thore Böckelmann
Status: newassigned

comment:7 Changed 5 years ago by Thore Böckelmann

In 3508:

  • mastertext.c: implemented a wrapper for graphics/TextLength() which breaks down the string into small chunks to be able to handle strings which exceed the pixel width of 32767. This refs #30.

comment:8 Changed 5 years ago by Thore Böckelmann

In 3509:

  • mastertext.c: implemented a wrapper for graphics/TextExtent() which breaks down the string into small chunks to be able to handle strings which exceed the pixel width of 32767. This refs #30.

comment:9 Changed 5 years ago by Thore Böckelmann

Resolution: fixed
Status: assignedclosed

In 3511:

  • List.c: restricted the maximum line width to 8192 pixels. Larger values might exceed the hardware limit and will cause graphical corruption. This closes #30.

comment:10 Changed 5 years ago by Thore Böckelmann

Cc: Roman Kargin added
Resolution: fixed
Status: closedreopened

According to Roman Kargin this issue is not yet fully fixed. Perhaps there is a relation between the maximum list width and the screens depth which might limit the maximum bitmap width.

comment:11 Changed 5 years ago by Thore Böckelmann

Milestone: MUI 4.0-2014R4MUI 4.0-2014R5

Pushing this one to the next release.

comment:12 Changed 4 years ago by Thore Böckelmann

Milestone: MUI 4.0-2014R5MUI 4.0-2014R6

Pushed to the next milestone.

comment:13 Changed 4 years ago by Thore Böckelmann

Milestone: MUI 4.0-2014R6MUI 4.0-2015R1

Milestone renamed

comment:14 Changed 4 years ago by Thore Böckelmann

This issue should be fixed with the next nightly build. At least for me everything is working correctly now. Please reopen the ticket otherwise.

comment:15 Changed 4 years ago by Thore Böckelmann

Resolution: fixed
Status: reopenedclosed

comment:16 Changed 4 years ago by Thore Böckelmann

Milestone: MUI 4.0-2015R14.0-2015R1

Milestone renamed

Note: See TracTickets for help on using tickets.