Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#29 closed bug (fixed)

Glitch/bug on the Odyssey download window

Reported by: Samir Hawamdeh Owned by: Thore Böckelmann
Priority: normal Milestone: 4.0-2014R4
Component: List.mui Version: 4.0-2014R3
Severity: minor Keywords:
Cc: OS Platform: AmigaOS4
Blocked By: Blocking:
Release Notes:

Description

This was originally reported by Raziel

http://www.amigans.net/modules/xforum/viewtopic.php?post_id=90392#forumpost90392


I found a visual glitch/bug in the download window.

Could be OWB itself, could be MUI, i don't really know.

Steps to reproduce:

1) Download something big and let the window come up.
2) Resize the window to make it as small as possible.
3) Now use the bottom scroll panel to reach the missing information, like progress, detail, speed etc.
—> The information is missing, nothing is rendered there
4) Now resize the window again
—> Everthing is back to normal

I'd like to ask if a redraw of the window can be added when one is scrolling with the bottom scroll panel (probably both scroll panels have the same problem) because i'm not really fond of the fact i need to resize the download window every time a download with a long filename takes place.

EDIT:

Oh yes and one more thing in the Downloads window

If one resizes it to the minimum, one can click only ONCE on the arrows beside the tabs.
It will work once but then no more.

i.e. switching from the "In Progress" tab to the "Finished" tab —> it will be stuck at the "Finished" tab until one resizes again to make the window bigger


Attachments (1)

download_bug.png (15.0 KB) - added by Samir Hawamdeh 5 years ago.

Download all attachments as: .zip

Change History (4)

Changed 5 years ago by Samir Hawamdeh

Attachment: download_bug.png added

comment:1 Changed 5 years ago by Thore Böckelmann

Component: Area.muiList.mui
Milestone: MUI 4.0-2014R4
Owner: set to Thore Böckelmann
Priority: undecidednormal
Status: newassigned

comment:2 Changed 5 years ago by Thore Böckelmann

Resolution: fixed
Status: assignedclosed

In 3483:

  • List.c: always draw complete lines, even if some parts are currently out of the visible area. This closes #29.

comment:3 Changed 4 years ago by Thore Böckelmann

Milestone: MUI 4.0-2014R44.0-2014R4

Milestone renamed

Note: See TracTickets for help on using tickets.