Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#261 closed enhancement (duplicate)

MUIV_Listtree_Insert_ListNode_Active not implemented

Reported by: Richard Lake Owned by:
Priority: normal Milestone: 4.0-2015R4
Component: Listtree.mcc Version: 4.0-2015R3
Severity: minor Keywords:
Cc: OS Platform: All
Blocked By: Blocking:
Release Notes:

Description

Summary

"Handling of MUIV_Listtree_Insert_ListNode_Active in MUIM_Listtree_Insert is missing completely."

For Trees with dynamic nodes and lists it is vital to be able to Insert at the Active list node when the name is not necessarily known please can you implement this ability and would have been originally intended.

INPUTS

ListNode:

Specify the node which list is used to insert the entry.

Special values:

MUIV_Listtree_Insert_ListNode_Active:

The list of the active node. (n/a)

Expected results

Insert the Item at the Active list node as given in the method.

Actual results

Doesn't do anyhing.

Regression

Not yet implmented.

Notes

Further information: http://muidev.de/ticket/257#comment

Change History (2)

comment:1 Changed 5 years ago by Thore Böckelmann

Priority: undecidednormal
Resolution: duplicate
Status: newclosed
Type: taskenhancement

I have no clue why you opened this ticket. The formerly unimplemented special value MUIV_Listtree_Insert_ListNode_Active is implemented now and is working. This becomes clear when you read this commit comment: https://muidev.de/ticket/257#comment:4

My final question was what you are expecting from me other than to implement the missing stuff.

Honestly, if you think that MUIV_Listtree_Insert_ListNode_Active still does not what you expect it to do then you should have reopened #257 instead of opening a new ticket about exactly the same issue. But before you do that please read the updated Autodocs and really make sure whether MUIV_Listtree_Insert_ListNode_Active still is not working. And if you still get a crash then please provide the crashlog.

To make it short, I will close this ticket as duplicate of #257, because I am sure everything is already done. Continue the discussion there.

comment:2 Changed 5 years ago by Thore Böckelmann

Milestone: future release4.0-2015R4
Note: See TracTickets for help on using tickets.