Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#237 closed enhancement (wontfix)

MUI4 Light

Reported by: Mikhail Malyshev Owned by:
Priority: undecided Milestone: 4.0-2015R3
Component: undefined Version: 4.0-nightly build
Severity: minor Keywords:
Cc: OS Platform: AmigaOS3
Blocked By: Blocking:
Release Notes:

Description

Problem

MUI4 is fairly complicated in some places and overloads legacy hardware when there is no reason for it. MUI3.9(2014) is half way nowhere and finished?

Enhancement recommendation

Create a new branch based on the MUI4 tree with following simplifications (roughly what MUI39(2005) had):

  1. Make settings changing optional (realtime or classic test button), still good for all versions
  1. Use boopsi for scrollers (we know the limitations)
  1. Simple requesters for colours (boopsi wheel), fonts, frames, patterns, simplified image requester (not loading all at once)

This would make MUI a much more pleasant experience for everybody (depending on available hardware) and allow modern software developers to use new/current MUI features and unify development.

Change History (5)

comment:1 Changed 5 years ago by Jens Maus

Resolution: wontfix
Status: newclosed

I will simply reject this request since we have more important stuff to do and classic hardware is obsolete and underpowered and not the target platform for MUI4. Face it!. And stop these kind of requests or we will immediately stop providing versions for classic machines.

comment:2 Changed 5 years ago by Mikhail Malyshev

That's perfectly fine, even better if it can be made as an option setting in the main build. Something like enable advanced settings, otherwise play simple (something like test mode for unregistered users).
This is not a priority thing, just something to look forward if time allows it, and it does not require inventing anything, just branch on condition to use some older code.

comment:3 Changed 5 years ago by Jens Maus

Well, I think you didn't listen (again): We won't do any further tuning/modifications to MUI4 just to improve compatibility to classic hardware. Classic hardware is obsolete and not the target for MUI4 at all. If you want to use MUI with classic hardware keep your MUI3.8 version installed and use that one instead. MUI4 will never be optimized to run faster/better/nicer on classic hardware!

So STOP your requests here to improve compatibility to classic hardware!

comment:4 Changed 5 years ago by Mikhail Malyshev

Just to clear a few things…
This are not just my complaints but of a small community.

Personally I am 'ok' with what we have and how it works on the higher end classics, OS4 and UAE based systems.

comment:5 Changed 5 years ago by Jens Maus

Well, and that's the point. The amaount of people is too small to imrpove support for classic systems in MUI4 and the hardware is too underpowered to improve it any further. That's actually the reason why stefan stuntz also never meant to release anything newer than MUI3.8 for 68k systems in the beginning. Now that you have MUI3.9 for classic systems with a reasonable performance there is really no reason to request more optimizations for classic systems for MUI4.0 since it was never meant as a target platform for MUI4.0. and as I said, in the future we will probably think about abadoning support for MUI4.0 for classic hardware systems all together and just support m68k UAE environments. And we really think people that are still using classic hardware and want to run something like MUi4 on these old systems are really crazy. We are in 2015 and time has moved on. Thus, people should throw away there classic systems and better support new amiga hardware/systems to keep the Amiga community alive. If everyone would still use old classic systems Amiga would have already died years ago.

Note: See TracTickets for help on using tickets.