Opened 5 years ago

Closed 5 years ago

#162 closed bug (fixed)

Left and right cursors don't work in odyssey

Reported by: YesCop Owned by:
Priority: normal Milestone: 4.0-2015R2
Component: Virtgroup.mui Version: 4.0-2015R1
Severity: minor Keywords:
Cc: Hubert Maier OS Platform: AmigaOS4
Blocked By: Blocking:
Release Notes:

Description

Summary

Well,
as requested by Thomas, I create a new ticket even I don't know if it is a mui bug.
Just after installing the new version of mui on OS4 4.1.6 (mui 4.0 2015R1), the left and right cursors don't work in the Odyssey browser. It is very paintful to edit this post…
I reset the default keyboard values (these values were never modified.).
I have no clue about that (except a problem with the OS4 version, need the os4 final?).
It seems that only two persons have this problem. The solution of the another one was to rollback to previous version.

Steps to reproduce

  1. just install this version of mui.


Attachments (1)

muimaster_no_virt_keys.lha (375.4 KB) - added by Thore Böckelmann 5 years ago.
muimaster.library without keyboard handling in Virtgroup.mui

Download all attachments as: .zip

Change History (15)

comment:1 Changed 5 years ago by Hubert Maier

I too have this behaviour (on different forums) with Odyssey.

Like right now, it doesn't move to left or right with the cursor.
I haven't changed anything in the MUI settings (everythings on default).

The funny thing is that sometimes it works and sometimes it won't.

i.e. i was just writing a post on the Hyperion forums and it worked as it should on one line but refused to on the other.
Once it happens it stays at being broken behaviour.

I'm trying to see if i can find some more information on why this could happens.
This is really an annoying behaviour

comment:2 Changed 5 years ago by Thore Böckelmann

Cc: Hubert Maier added

Changed 5 years ago by Thore Böckelmann

Attachment: muimaster_no_virt_keys.lha added

muimaster.library without keyboard handling in Virtgroup.mui

comment:3 Changed 5 years ago by Thore Böckelmann

The only modification since the last release I can think of is the keyboard support of virtual groups for scrolling. Perhaps that has an impact on Odyssey, although the browser object is no instance of Virtgroup.mui. Please try the attached version and report back.

comment:4 Changed 5 years ago by Hubert Maier

Using muimaster_no_virt_keys.library doesn't fix the behaviour but brings up a new one.

I have the Bookmarks "tab" open in the left side of Odysseys main window.
Typing this message will scroll the Bookmark entries to the left or right when pressing the left/right cursor keys (depending on how long the entries are and on which position they are displayed, obviously the first time only the "to right" cursor "works") even if i'm inside the activated write/textarea window.

It doesn't matter on which site i am.

Thank you for the quick feedback though

comment:5 Changed 5 years ago by Thore Böckelmann

In 4505:

  • Virtgroup.c, mcc/Aboutbox.c: moved the keyboard based scrollling from Virtgroup.mui to Aboutbox.mcc where it was originally requested for. This refs #125 and refs #162.

comment:6 Changed 5 years ago by Thore Böckelmann

Please try again with the upcoming nightly build. I should behave like 2014R5. Unfortunately I am lacking the time to test this on AmigaOS4 myself today.

comment:7 Changed 5 years ago by Hubert Maier

Haven't checked the nightly build yet (it's not up anyway right now)

But further tests brought up the reason for the non-working cursor keys.
I have to add up-front that it worked as should with the last revision.

In Odyssey it's possible to open "sticky" Sidebars (History and Bookmarks).
Once those sidebars are there the cursors stop to work in the main browser window, instead they are somehow "assigned" to the sidebar "tabs".

This can easily be cross-checked with your muimaster_no_virt_keys.lha version.
Once this is used and a sidebar is open, any right/left cursor input (i.e. in a forum topic text field) will end up scrolling the sidebar.
(The "normal" version will only eat away the cursor presses.

It doesn't matter which sidebar is open, happens with both or with only one of the two.

But, if one closes all sidebars so that only the main broswer window is there, the cursor keys work as expected again (tested with normal version and muimaster_no_virt_keys.lha.

comment:8 in reply to:  7 Changed 5 years ago by Thore Böckelmann

Replying to Raziel:

Haven't checked the nightly build yet (it's not up anyway right now)

It will be built at 02:00 CET as usual.

In Odyssey it's possible to open "sticky" Sidebars (History and Bookmarks).
Once those sidebars are there the cursors stop to work in the main browser window, instead they are somehow "assigned" to the sidebar "tabs".

The side bars are simple list objects which default to be the window's active object and hence see any input ahead of all other objects. If their content is too wide ans lets the list scroll horizontally then the key presses will be swallowed by them, no matter which other object might be interested in them.

But, if one closes all sidebars so that only the main broswer window is there, the cursor keys work as expected again (tested with normal version and muimaster_no_virt_keys.lha.

Of course, because then there is no other object which could "eat" the key presses.

comment:9 Changed 5 years ago by Hubert Maier

The side bars are simple list objects which default to be the window's active object and hence see any input ahead of all other objects. If their content is too wide ans lets the list scroll horizontally then the key presses will be swallowed by them, no matter which other object might be interested in them.

That sounds as if that is intended behaviour and no way to change it?

But why did it "work" with the last revision?
I didn't change anything regarding the width or entries of my Bookmarks.
I kept everything as it was before the update (i even did a complete restore of my Odyssey backup)

comment:10 Changed 5 years ago by Thore Böckelmann

Reporter: changed from anonymous to YesCop

comment:11 Changed 5 years ago by Hubert Maier

Using muimaster.library 20.6383 (20.02.2015) from nightly now and everything's back to normal.
Cursor keys work as expected :-)

Thanks a lot

comment:12 in reply to:  10 ; Changed 5 years ago by YesCop

Replying to tboeckel:
Thomas, thanks for the changes of the name of the reporter and the lastest build of muimaster.library.

I tested, it worked. Could you tell me what was wong?
Thanks.

comment:13 in reply to:  12 Changed 5 years ago by Thore Böckelmann

Replying to YesCop:

Replying to tboeckel:
Thomas, thanks for the changes of the name of the reporter and the lastest build of muimaster.library.

My name is still Thore, not Thomas.

I tested, it worked. Could you tell me what was wong?

Any virtual group within the window would just "eat" any cursor key press if could be scrolled in any direction. Now Virtgroup.mui is back to the old state and the keyboard scrolling is implemented for Aboutbox.mcc only, which is the class this feature was requested for originally.

comment:14 Changed 5 years ago by Thore Böckelmann

Component: undefinedVirtgroup.mui
Milestone: 4.0-2015R2
Priority: undecidednormal
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.