Opened 5 years ago

Closed 5 years ago

#152 closed bug (fixed)

Image colour remapping problem

Reported by: Mikhail Malyshev Owned by: Thore Böckelmann
Priority: normal Milestone: 4.0-2015R2
Component: Imagespace.mui Version: 4.0-AmiKit8.2
Severity: minor Keywords:
Cc: OS Platform: AmigaOS3
Blocked By: Blocking:
Release Notes:

Description

Ok, another extreme case you would not like…

We are in 4 colour mode, and as you can see the checkmark and radio button images are remapped as plain (while multiview shows them correctly)

MUI 3.9 displays them ok too.

Actually tried 8c, 16c, 32c modes and still MUI 4.0 fails to display them correctly.

Something wrong with remapping or drawing routine of 4.0

Attachments (3)

remap.png (9.0 KB) - added by Mikhail Malyshev 5 years ago.
remapping problems
mui-os4-8nit.png (54.6 KB) - added by Mikhail Malyshev 5 years ago.
muios4-16-to-8-bit.png (52.3 KB) - added by Mikhail Malyshev 5 years ago.

Download all attachments as: .zip

Change History (18)

Changed 5 years ago by Mikhail Malyshev

Attachment: remap.png added

remapping problems

comment:1 Changed 5 years ago by Thore Böckelmann

Component: undefinedImagespace.mui
Milestone: MUI 4.0-2015R1
Owner: set to Thore Böckelmann
Priority: undecidednormal
Status: newassigned

comment:2 Changed 5 years ago by Thore Böckelmann

Resolution: fixed
Status: assignedclosed

In 4446:

  • Imagespace.c: separated a flag check for truecolor and bitmap images to avoid loosing some state information in case a truecolor image is not available and the bitmap image must be used instead. This closes #152.

comment:3 Changed 5 years ago by Mikhail Malyshev

Please recheck under OS4 colour mapped screens.
The checkmark, radiobutton images are still plain.
Also looks like problems with popupmenu button image (now it's black)
And backgrounds possibly remap wrongly too.

comment:4 Changed 5 years ago by Thore Böckelmann

Which image files exactly are you referring to?

comment:5 Changed 5 years ago by Mikhail Malyshev

The same as in screen shot above (remap.png)

Changed 5 years ago by Mikhail Malyshev

Attachment: mui-os4-8nit.png added

Changed 5 years ago by Mikhail Malyshev

Attachment: muios4-16-to-8-bit.png added

comment:6 Changed 5 years ago by Mikhail Malyshev

Two more screens, First is if you run MUI on 8 bit screen.
Second, if you run MUI on 16bit screen and then switch to 8-bits and run it again.
And this is not the worst case of background corruption and gadgets.
The OS/Reaction based prefs adapt without problems.

comment:7 Changed 5 years ago by Mikhail Malyshev

Interestingly, the OS3 builds of MUI4 do not seem to be effected as much as OS4 ones.

comment:8 Changed 5 years ago by Mikhail Malyshev

Resolution: fixed
Status: closedreopened

Tokai and default_OS4 images in *.mim format are rendered black on 8 bit screens.

comment:9 Changed 5 years ago by Thore Böckelmann

Honestly, I am unable to reproduce your problem. And it is really hard to know what platform you are talking about, because you seems to switch between WinUAE/AmiKit and AmigaOS4 constantly, but unfortunately without telling exacty which platform you are referring to.

comment:10 Changed 5 years ago by Mikhail Malyshev

Should be obvious from the picture names - OS4.
The last 3 messages are all about the same.
Sorry if it was not clear enough.

comment:11 Changed 5 years ago by Thore Böckelmann

For me AmigaOS4 just locks up completely shortly after the Workbench is opened again with the new screenmode/depth.

This might be caused by the fact that Imagespace.mui is not (yet) notified for a to be closed Workbench screen. This will leave all images bound to this screen alive. It then might happen that the newly opened Workbench screen gets exactly the same address and hence MUI will just reuse the old and still alive images. But since these images refer to a no longer existing screen and hence might cause any kind of funny things to happen.

comment:12 Changed 5 years ago by Thore Böckelmann

In 4471:

  • Imagespace.c, Application.c: request a notification for a to be closed Workbench as well to flush the images mapped to this screen just like for any other screen. This refs #152 and refs #156.

comment:13 Changed 5 years ago by Thore Böckelmann

Milestone: MUI 4.0-2015R1MUI 4.0-2015R2

Pushed to next milestone.

comment:14 Changed 5 years ago by Thore Böckelmann

Milestone: MUI 4.0-2015R24.0-2015R2

Milestone renamed

comment:15 Changed 5 years ago by Thore Böckelmann

Resolution: fixed
Status: reopenedclosed

Just like #156 this one should be fixed now.

Note: See TracTickets for help on using tickets.