Opened 5 years ago

Closed 4 years ago

#15 closed bug (fixed)

Little glitch in OWB using the "Hide single tabs" option

Reported by: Samir Hawamdeh Owned by:
Priority: normal Milestone: 4.0-2015R2
Component: Title.mui Version: 4.0-2014R2
Severity: minor Keywords:
Cc: Roman Kargin OS Platform: AmigaOS4
Blocked By: Blocking:
Release Notes:

Description

Using Odyssey with the latest version of MUI you sent me still some graphical garbage having the new option "Hide single tab" enabled.

This is pretty visible when you close your last (secondarian tab) tab opened and so remaining with a unique tab only

Once you close this latest tab, for a second you will have this graphical garbage

Attachments (1)

glitch.png (144.9 KB) - added by Samir Hawamdeh 5 years ago.

Download all attachments as: .zip

Change History (22)

comment:1 Changed 50 years ago by Samir Hawamdeh

Status: pendingnew

comment:2 Changed 50 years ago by Samir Hawamdeh

Status: pendingnew

Changed 5 years ago by Samir Hawamdeh

Attachment: glitch.png added

comment:1 Changed 5 years ago by Thore Böckelmann

Milestone: MUI 4.0-2014R4
Priority: undecidednormal
Status: newpending

Please try to reproduce this issue with the lastest MUI release R3 and Odyssey 1.23.

comment:2 Changed 5 years ago by Samir Hawamdeh

@Thore

Yes this happen also with the latest MUI4 and Odyssey 1.23
To reproduce it do that:

  • 1 - Make sure you have "Hide single tab" active into your MUI setting
  • 2 - You need to have atleast 2 tabs opened in OWB, in the first tab try to load a site with a "long" page, aka so long to be able to add a scrollbar into the browser (for example load: www.amigans.net)
  • 3 - At this point just open another tab as you like, even a blank page (the important is to have atleast two tabs opened)
  • 4 - Now close this second tab
  • 4b - In the exact moment you close it the only page remained opened will be of course the www.amigans.net one, but just after you close this second tab you should also note a little glitch, aka a strange extra scrollbar will be showed for a couple of second to the left part of the page (see the glitch.png image above)

comment:3 Changed 5 years ago by Roman Kargin

Yeah, can reproduce it on my setup too as well (peg2/beta os4/latest odyssey/latest mui)

comment:4 Changed 5 years ago by Thore Böckelmann

Milestone: MUI 4.0-2014R4MUI 4.0-2014R5

Pushing this one to the next release.

comment:5 Changed 5 years ago by Thore Böckelmann

Milestone: MUI 4.0-2014R5MUI 4.0-2014R6

Pushed to the next milestone.

comment:6 Changed 4 years ago by Thore Böckelmann

Ticket #134 refers to the same problem.

comment:7 Changed 4 years ago by Thore Böckelmann

Milestone: MUI 4.0-2014R6MUI 4.0-2015R1

Milestone renamed

comment:8 Changed 4 years ago by Thore Böckelmann

Milestone: MUI 4.0-2015R1MUI 4.0-2015R2

Pushed to next milestone.

comment:9 Changed 4 years ago by Thore Böckelmann

Milestone: MUI 4.0-2015R24.0-2015R2

Milestone renamed

comment:10 Changed 4 years ago by Thore Böckelmann

Cc: Roman Kargin added
Status: newpending

Is anybody still able to reproduce this issue with the 2015R1 release of MUI4 or even better one of the latest nightly builds?

Hiding the title object when the next to last tab is closed will cause a complete redraw of the the last visible page. If that is still causing screwed contents then this is an issue of Odyssey. I had a quick look at the MUIM_Draw method of the browser class and noticed it is using some kind of a "dirty area" approach. Perhaps the last remembered "dirty area" is not calculated correctly or is no longer valid but still used for the redraw operation. If that is the case then there is nothing I can do about that and a similar screwed display could happen at any time an not only with the "hide single tabs" option active.

comment:11 Changed 4 years ago by Samir Hawamdeh

@Thore

Right now i'm using the very latest nighltly but i have exactly the same graphical glitch that i had 1 year ago —> this one:

http://muidev.de/attachment/ticket/15/glitch.png

I used the same method to reproduce it.

1 - I activated the "hide single tabs" in MUI prefs
2 - I open Odyssey with atleast 2 tabs
3 - I closed one of that tab in order to remain with 1 tab opened only
—> At this point (for a little moment) i can note this graphical issue (see image above)

comment:12 Changed 4 years ago by Samir Hawamdeh

Aniway to me the main problem are the strange additional scrollbar visible to the left, for a strange reason the scrollbar appear to the left side of the window rathen then to the right side of the window (as it should)

Regarding the corrupted content inside the page it might be related to the loading of the html's content for itself .. don't know.

comment:13 Changed 4 years ago by Samir Hawamdeh

Very strange, since MUI4 svn r4609 now anytime i open a new tab in Odyssey i can see the (graphical) glitch !

http://muidev.de/attachment/ticket/15/glitch.png

No matter if i have the "hide single tabs" activated or not, now the problem is always noticiable
Well interesting, maybe this info might help :-)

comment:14 Changed 4 years ago by Thore Böckelmann

In 4618:

  • Title.c: reverted the change to always do a full relayout when a tab was added or removed. This refs #15.

comment:15 Changed 4 years ago by Thore Böckelmann

Did the recent changes to Title.mui change anything here?

comment:16 Changed 4 years ago by Samir Hawamdeh

No, this ticket has not been fixed yet !
Of course latest changes fixed the recent issues, but now all turned exactly as it was before.

comment:17 Changed 4 years ago by Thore Böckelmann

In 4633:

  • Title.c: changed the relayout approach after hiding/showing single tabs and after adding/removing the automatic close button. This refs #15.

comment:18 Changed 4 years ago by Samir Hawamdeh

Sorry mate i just forgot to give you the final confirmation, this bug is finally solved thanks to your latest related commit (r4633)

You can close the ticket, big thanks ! :-)

comment:19 Changed 4 years ago by Thore Böckelmann

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.