Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#132 closed bug (invalid)

ListTree Nodes missing graphics

Reported by: Richard Lake Owned by: Thore Böckelmann
Priority: normal Milestone: 4.0-2015R1
Component: Listtree.mcc Version: 4.0-2014R5
Severity: minor Keywords:
Cc: Andreas Falkenhahn OS Platform: AmigaOS4
Blocked By: Blocking:
Release Notes:

Description

Summary

Steps to reproduce

  1. Install AmigaOS 4.1 Final Edition 2.

Expected results

After installing AmigaOS 4.1 Final Edition from clean, the square node graphics are missing from the ListTree class as can be seen the screenshot below.

http://postimg.org/image/s9x7gsxw5/

Actual results

[url=http://postimg.org/image/s9x7gsxw5/][img]http://s10.postimg.org/s9x7gsxw5/Jack_Screen_Capture0.jpg[/img][/url]

Regression

Notes

Attachments (3)

Jack_Screen_Capture0.png (115.5 KB) - added by Thore Böckelmann 4 years ago.
Screenshot of missing node images
muibuilder_muidebug (194.2 KB) - added by Richard Lake 4 years ago.
Ran MUIBuilder, went to Layout tab, clicked on a few nodes closing them.
listtree_muidebug (14.5 KB) - added by Richard Lake 4 years ago.

Download all attachments as: .zip

Change History (20)

comment:1 Changed 4 years ago by Richard Lake

Just to clarify, the top node is defined as a List node 'Text Options' and the visible square -/+ is missing from the render. If you look in the Odyssey bookmark manager the square is missing there too.

comment:2 Changed 4 years ago by Thore Böckelmann

Milestone: MUI 4.0-2014R6
Owner: set to Thore Böckelmann
Priority: undecidednormal
Status: newassigned

First of all, please refrain from using external links for screenshots. Such links are bound to vanish sooner or later and are no longer available for later reference. This bugtracker offers the possibility to attach arbitrary files to a ticket. This is a much better solution.

Apart from that I will take a look what exactly is missing here.

comment:3 Changed 4 years ago by Thore Böckelmann

Just a quick question. This happens with the default MUI configuration without any modification. Correct?

Last edited 4 years ago by Thore Böckelmann (previous) (diff)

comment:4 Changed 4 years ago by Thore Böckelmann

In 4367:

  • mcc/Listtree_mcp.h: slightly changed the default image spec. This refs #132.

comment:5 Changed 4 years ago by Thore Böckelmann

The default node images are MUI:Images/default_OS4/Listtree1.mi1 and MUI:Images/default_OS4/Listtree1.mi2. What is a bit puzzling in the case is the fact that Listtree.mcc defaults to using the "Win95" style which doesn't use external images at all but draws the images itself. Hence you cannot be using the unmodified default settings.

Did you already make sure that the images are available in MUI:Images/default_OS4?

comment:6 Changed 4 years ago by Richard Lake

ArrowDown.mim ArrowLeft.mim ArrowRight.mim
ArrowUp.mim Assign.mi1 CheckMark.mim
Chip.mi1 CloseButton_framed.mim Cycle_framed.mim
Disk.mi1 Drawer.mi1 HardDisk.mi1
Listtree1.mi1 Listtree2.mi1 Network.mi1
PopDrawer.mim PopFile.mim PopFont.mim
PopUp.mim PullOpen.mim RadioButton_framed.mim
smallerw.png TapeDown.mi1 TapePause.mi1
TapePlay.mi1 TapePlayBack.mi1 TapeRecord.mi1
TapeStop.mi1 TapeUp.mi1 Volume.mi1

contents of MUI:Images/default_OS4 folder

The only modification I have made to MUI Settings is that Hide Single Tab option under Groups. Talking of which are you are to make that option Enabled by default? Makes sense if the application in question is a browser.. not sure of further implications of making that switch; can't imagine any negative consequences of making that the norm.

I will refer this ticket to Andreas (Hollywood) I assume he has an account here also - in reference to that #132 link you posted above.

Last edited 4 years ago by Richard Lake (previous) (diff)

comment:7 Changed 4 years ago by Thore Böckelmann

Cc: Andreas Falkenhahn added

Please install the debug version of muimaster.library and create an IMAGE debug log with that version.

Details of the debug version can be found in the FAQ.

Changed 4 years ago by Thore Böckelmann

Attachment: Jack_Screen_Capture0.png added

Screenshot of missing node images

comment:8 Changed 4 years ago by Thore Böckelmann

Milestone: MUI 4.0-2014R6MUI 4.0-2015R1

Milestone renamed

comment:9 Changed 4 years ago by Thore Böckelmann

According to the discussion here http://www.amigans.net/modules/xforum/viewtopic.php?post_id=95356#forumpost95356 this issue is unrelated to #133.

Did you try to reset your MUI settings to default values already?

Listtree.mcc definitely uses MUI:Images/default_OS4/Listtree1.mi1 and MUI:Images/default_OS4/Listtree2.mi1 as default treenode images. But the default style is Win95 which does not require any external images at all, but draws the "+" and "-" images internally.

So unless you did not modify these settings yourself or replaced the global configuration file from it is not possible that Listtree.mcc should require the external images.

Furthermore two weeks have passed already since I asked you to provide a debug log created with the debug version of muimaster.library. Could I get this log please?

comment:10 Changed 4 years ago by Richard Lake

Okay I am going to have a look at this now.

comment:11 Changed 4 years ago by Richard Lake

Trying to supply Listtree muidebug image as well, but Sashimi just keeps DSI-ing every time now.

comment:12 Changed 4 years ago by Richard Lake

Results from the nightly build.

MUI-4.0-20150124r4420-os4-debug.lha 1.1 MB 01/24/2015 02:00:29 AM 1d4c92aa79f8dee02149c61246fecbe4

comment:13 Changed 4 years ago by Thore Böckelmann

Unfortunately the log is useless, because you forgot to set the ENV variable "muidebug" ahead of using the debug version:

muimaster.li CheckDebug       : GetVar("ENV:muidebug") failed, error 205

Error 205 means "object not found".

Please type "setenv muidebug image" in a Shell before running MUIBuilder as first MUI application. Without the correct variable contents you won't produce the log I was asking for. If you have any questions about the debug version then please read the details in the FAQ or just ask.

Changed 4 years ago by Richard Lake

Attachment: muibuilder_muidebug added

Ran MUIBuilder, went to Layout tab, clicked on a few nodes closing them.

Changed 4 years ago by Richard Lake

Attachment: listtree_muidebug added

comment:14 Changed 4 years ago by Richard Lake

Sorry about that thought I had set the variable correctly, as you can see this evening Sashimi wasn't being a pain and I managed to get debug logs from both .exes

comment:15 Changed 4 years ago by Thore Böckelmann

Resolution: invalid
Status: assignedclosed

Thanks for the logs. But they clearly proof that you are not using the default configuration as you originally stated:

148	Imagespace.c CreateBrushImage : default_OS4/ListDrawer1.mbr
149	Imagespace.c AllocImage       : 9 size=96 '3:default_OS4/ListDrawer1.mbr' screen=60def9c0
150	Imagespace.c FreeImage        : 3:default_OS4/ListDrawer1.mbr (screen=60def9c0)
151	Imagespace.c CreateBrushImage : default_OS4/ListDrawer1.mbr failed
152	Imagespace.c CreateAlienImage : default_OS4/ListDrawer1.mbr
153	Imagespace.c AllocImage       : 10 size=92 '3:default_OS4/ListDrawer1.mbr' screen=60def9c0
154	Imagespace.c FreeImage        : 3:default_OS4/ListDrawer1.mbr (screen=60def9c0)
155	Imagespace.c CreateImage      : ok at 00000000 <FAILED>

The image your config is referring to is named default_OS4/ListDrawer1.mbr instead of default_OS4/ListDrawer1.mi1 and since the latter one is missing in your directory MUI:Images/default_OS4 it is obvious that MUI must fail loading it and hence cannot display it.

Go to the prefs page of Listtree and reset its settings to default values. Everything will be working again then.

comment:16 Changed 4 years ago by Richard Lake

Well I don't know how that came to be, but it is solved now and I can see that it is fixed. However, I had to go to SYS:MUI/MUI and reset global values that way rather than through the prefs page of my Listtree application.

PS. Spotted the 'More>' button at the bottom of the ListView which reveals the 'Listtree' panel - never noticed that there before.

Thank you.

Last edited 4 years ago by Richard Lake (previous) (diff)

comment:17 Changed 4 years ago by Thore Böckelmann

Milestone: MUI 4.0-2015R14.0-2015R1

Milestone renamed

Note: See TracTickets for help on using tickets.