Opened 6 years ago

Closed 6 years ago

Last modified 5 years ago

#126 closed bug (fixed)

New/old enforcers

Reported by: Mikhail Malyshev Owned by: Thore Böckelmann
Priority: normal Milestone: 3.9-2015R1
Component: Framedisplay.mui Version: 3.9-nightly build
Severity: minor Keywords:
Cc: OS Platform: AmigaOS3
Blocked By: Blocking:
Release Notes:

Description

Just a few hits I found while playing with latest nightly MUI3.9 build

Only happens once when you first time click on their prefs items:

LayGroup.mcp

Calendar.mcp

Attachments (1)

mui39-hits.txt (4.4 KB) - added by Mikhail Malyshev 6 years ago.

Download all attachments as: .zip

Change History (7)

Changed 6 years ago by Mikhail Malyshev

Attachment: mui39-hits.txt added

comment:1 Changed 6 years ago by Thore Böckelmann

Component: undefinedFramedisplay.mui
Milestone: MUI 3.9-2014R4
Owner: set to Thore Böckelmann
Priority: undecidednormal
Status: newassigned

The hits caused by LayGroup.mcp happen, because an invalid frame spec is used. This can be catched. However, the hits of Calendar.mcp happen inside that class. There is no way for MUI to do anything against NULL pointer acesses outside its scope. NULL pointers are no bug and must always be handled accordingly.

Finally there are more hits happening for LayGroup.mcp after closing MUI prefs which are a following error of previous invalid memory accesses. There is nothing that can be done to fix this in MUI. Blame the original developer for his lazyness.

comment:2 Changed 6 years ago by Thore Böckelmann

Resolution: fixed
Status: assignedclosed

In 4290:

  • Framedisplay.c: added an additional check for invalid frame specs. This closes #126.

comment:3 Changed 6 years ago by Mikhail Malyshev

Calendar.mcp 18.3 (according to changes log - a lot of bug fixes!)
Older Calendar.mcp 18.0 works without any hits.

comment:4 Changed 6 years ago by Thore Böckelmann

There is nothing that I could do to fix these many many many fixed bugs in Calendar.mcp. MUI is not at fault here.

comment:5 Changed 6 years ago by Thore Böckelmann

Milestone: MUI 3.9-2014R4MUI 3.9-2015R1

Milestone renamed

comment:6 Changed 5 years ago by Thore Böckelmann

Milestone: MUI 3.9-2015R13.9-2015R1

Milestone renamed

Note: See TracTickets for help on using tickets.