Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#111 closed enhancement (fixed)

Missing translation in one ASL requester

Reported by: Samir Hawamdeh Owned by: Thore Böckelmann
Priority: normal Milestone: 4.0-2015R1
Component: String.mui Version: 4.0-2014R5
Severity: minor Keywords:
Cc: OS Platform: AmigaOS4
Blocked By: Blocking:
Release Notes:

Made the title string of the "Insert text file" ASL requester translatable.

Description

Just a very very little missing, one of title of an ASL window is not yet translable
the exact string is:

Insert text file…

You can reach it from the color wheel, choose the preferred color, then inside the user box select again the "insert a text file" menu

This will open the involved ASL requester, see grab

Attachments (3)

asl.png (926.1 KB) - added by Samir Hawamdeh 4 years ago.
notitle.png (947.2 KB) - added by Samir Hawamdeh 4 years ago.
italian_mui.png (328.0 KB) - added by Thore Böckelmann 4 years ago.
MUI with italian translation

Change History (18)

Changed 4 years ago by Samir Hawamdeh

Attachment: asl.png added

comment:1 Changed 4 years ago by Thore Böckelmann

Component: undefinedString.mui
Milestone: MUI 4.0-2014R6
Owner: set to Thore Böckelmann
Priority: undecidednormal
Status: newassigned

comment:2 Changed 4 years ago by Thore Böckelmann

Resolution: fixed
Status: assignedclosed

In 4137:

  • String.c: made the title string of the "Insert text file" ASL requester translatable. This closes #111.

comment:3 Changed 4 years ago by Samir Hawamdeh

Checked again with the latest version of MUI4 (r4212) and i need to reopen this ticket because it doesn't seems completely fixed

The title string: "Insert text file…" that should be used for the title of this ASL requester is now completely empty.

I already translated them but maybe they are not applied

Changed 4 years ago by Samir Hawamdeh

Attachment: notitle.png added

comment:4 Changed 4 years ago by Thore Böckelmann

Are you sure you have the latest italian catalog installed? It should be V20.4154.
Although I am using the german translation the title is correctly translated. As such everything is working properly basically.

comment:5 Changed 4 years ago by Samir Hawamdeh

MUI/Locale/Catalogs/Italian —> V20.4166 (9-Nov-2014)

Mmm maybe i have an old copy somewhere ?

comment:6 Changed 4 years ago by Samir Hawamdeh

Just did a quick search and i have this catalog only, well i have one in RollBack but i doubt it will be used

comment:7 Changed 4 years ago by Thore Böckelmann

You can check the version of the used catalog with Scout. And perhaps you should do a search for duplicate MUI catalogs on your hard disk. I just switched my system to italian and the title is shown correctly.

comment:8 Changed 4 years ago by Thore Böckelmann

Any progress here?

comment:9 Changed 4 years ago by Thore Böckelmann

Resolution: fixed
Status: closedreopened

comment:10 Changed 4 years ago by Samir Hawamdeh

@Thore

I did a couple of test, first i renamed the whole italian folder of my MUI4 directory, just to be sure that the only italian catalog used is the italian catalog that reside there.

At next restart MUI was in english, so i can confirm that there is only one (italian) catalog on my system and it's the latest and correct one

Second test: I mantain the english setting and then i open the involved ASL requester again, but even in english the title on that requester are NOT show .. very strange

Please can you provide a grab of your system ?

comment:11 Changed 4 years ago by Samir Hawamdeh

Mmmm thanks for the grab, you are right it work …
But in my system not and maybe i've also understand why .. a couple of weeks ago i temporarily changed back my date settings (switching back to some days) because MUI continue to annoy me with its expired requesters and so MUI programs refuse to start … as i didn't solve reinstalling a recent release i mantain this "fake" date but then i completely forget it ..

Ya it was my fault, didn't know that changing a date can created this kind of problem

You can close the ticket :-)

comment:12 Changed 4 years ago by Thore Böckelmann

Resolution: fixed
Status: reopenedclosed

New nightly builds are created automatically before the current build expires. Hence it should not be necessary to tweak the date. Please let us know if the nightly builds are not created in time.

Changed 4 years ago by Thore Böckelmann

Attachment: italian_mui.png added

MUI with italian translation

comment:13 Changed 4 years ago by Thore Böckelmann

Milestone: MUI 4.0-2014R6MUI 4.0-2015R1

Milestone renamed

comment:14 Changed 4 years ago by Thore Böckelmann

Release Notes: modified (diff)

comment:15 Changed 4 years ago by Thore Böckelmann

Milestone: MUI 4.0-2015R14.0-2015R1

Milestone renamed

Note: See TracTickets for help on using tickets.