Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#109 closed bug (invalid)

OWB Proxy Server bug in username field

Reported by: Phantom Owned by:
Priority: normal Milestone: 4.0-2015R1
Component: foreign application Version: 4.0-2014R4
Severity: minor Keywords:
Cc: OS Platform: AmigaOS4
Blocked By: Blocking:
Release Notes:

Description

I really don't know if that's MUI's fault or OWB's really, maybe you can check further?

The problem is that when I enter to use a Proxy Server from the Preferences menu in OWB 1.23, and type my username and password, after a while the username changes to my password, thus both username and password fields have my password!

Change History (3)

comment:1 Changed 5 years ago by Thore Böckelmann

Component: undefinedforeign application
Milestone: MUI 4.0-2014R6
Priority: undecidednormal
Resolution: invalid
Status: newclosed

Looking at the Odyssey source all I can tell is that two string objects are created and their contents are read out when ever the a configuration is loaded, saved or reset. Each string object in the window gets a unique ID to automatically set the contents, i.e. after loading a new configuration. However, I just noticed that in contrast to all other string objects the two in question get the same ID. This definitely causes all the trouble, because one setting will be applied to two objects with different tasks and hence cause the trouble you are experiencing. This can only be fixed in Odyssey.

Here are the some lines from prefswindowclass.cpp:

Child, str_proxyhost = (Object *) MakePrefsStringWithWeight(GSI(MSG_PREFSWINDOW_NETWORK_PROXY_HOST), "", 256, 80, MAKE_ID('S','N','P','H')),
Child, str_proxyport = (Object *) MakePrefsStringWithWeight(GSI(MSG_PREFSWINDOW_NETWORK_PROXY_PORT), "", 6, 20, MAKE_ID('S','N','P','P')),
Child, str_proxyusername = (Object *) MakePrefsString(GSI(MSG_PREFSWINDOW_NETWORK_PROXY_USERNAME), "", 128, MAKE_ID('S','N','P','U')),
Child, str_proxypassword = (Object *) MakePrefsString(GSI(MSG_PREFSWINDOW_NETWORK_PROXY_PASSWORD), "", 128, MAKE_ID('S','N','P','U')),

One can easily see that str_proxyusername and str_proxypassword get the same ID while all the others get unique IDs.

Contact the Odyssey developers for a fix.

comment:2 Changed 5 years ago by Thore Böckelmann

Milestone: MUI 4.0-2014R6MUI 4.0-2015R1

Milestone renamed

comment:3 Changed 5 years ago by Thore Böckelmann

Milestone: MUI 4.0-2015R14.0-2015R1

Milestone renamed

Note: See TracTickets for help on using tickets.