Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#6 closed bug (fixed)

Multiple tabs problems with OWB

Reported by: Samir Hawamdeh Owned by: Thore Böckelmann
Priority: normal Milestone: 4.0-2014R3
Component: Title.mui Version: 4.0-2014R2
Severity: minor Keywords:
Cc: OS Platform: AmigaOS4
Blocked By: Blocking:
Release Notes:

Fixed the sporadic non-working tab scrolling by adapting certain eventhandler priorities.

Description

Well to be honest in this case it's not so easy to write a specific report because there are many different issues that isn't easy to decifrate
But i will try ..

Just opened a number of blank tabs with OWB like this:

http://s29.postimg.org/8j7uuak6f/multiple_tabs.png

At this point into the tabs area you should see two clickable arrows that permit you to navigate between them

At this point we have a lot of different problems:

Problem 1:
When you click on the left arrow sometimes a "close button" appear like if OWB will want to try to close a tab instead of just moving between the tabs area and/or navigate between them

Problem 2:
Say you open a tab and load: www.amiga.com
Then open some blank tabs once you have covered the entire area (i mean once the 2 arrows appear)

Now just go the last blank tabs opened and start to close them one by one ..
At some point you should reach the www.amiga.com tab opened .. but no !
The first tabs opened with www.amiga.com tab was misteriously closed in background

Problem 3
Surely related to the problems above, at some point the new tabs opened will not be showed anymore .. you can start opening any number of tabs you like but the space will never be fitted:

http://s9.postimg.org/n88eh2aq7/tabs_issue.png

Well i know lot of different issue and any of them might need a specific report but ehm it seems all very bugged

Attachments (1)

Crashlog_OWB_2014-02-08_01-51-56.txt (33.2 KB) - added by Samir Hawamdeh 5 years ago.

Download all attachments as: .zip

Change History (12)

Changed 5 years ago by Samir Hawamdeh

comment:1 Changed 5 years ago by Samir Hawamdeh

Crashlog attached is of course related to the "problem 3"
On problems 3 I said that at some point the new tabs opened will not be showed anymore, so i closed OWB and so the crash happened ..

comment:2 Changed 5 years ago by Roman Kargin

I can confirm all of this , but it's not about tabs in general, but its all about handling of those "letf/right" things when there is many tabs and some of them moves to invisibly buffer. I.e. till you open amount of tabs which do not make for your left/right images and put tabs in buffer all is fine, but once, and you press on left one, all problems starts.

comment:3 Changed 5 years ago by Thore Böckelmann

I am quite sure all this has been fixed in the meantime. We will try to establish nightly builds as soon as possible to give you more instant feedback on fixed bugs. Just give us a few days.

comment:4 Changed 5 years ago by Samir Hawamdeh

@Thore

Thanks for the new internal beta, yes i can confirm that most problem i've reported above seems solved, aniway some issue still (well atleast one)

Once again i retest the thing opening tons of blank tabs until the 2 arrows will be showed, then i'm start pressing the left arrow in order to arrive to highlight the very first tab opened

Initially the mechanism seems working, but after 2 or 3 movement to the left —> the left arrow stop working and it doesn't react anymore

Aniway maybe all the things might be reorganized a bit, for example in the event we have a certain number of tabs opened we should add a scrollbar after a while .. or even better we should organized the things like the old MUI OWB 1.9 (the old "hack" tabs done by Denill) like adding a small popup that will contain all the tabs opened in excess

Last edited 5 years ago by Samir Hawamdeh (previous) (diff)

comment:5 in reply to:  4 Changed 5 years ago by Thore Böckelmann

Replying to samo79:

Once again i retest the thing opening tons of blank tabs until the 2 arrows will be showed, then i'm start pressing the left arrow in order to arrive to highlight the very first tab opened

Initially the mechanism seems working, but after 2 or 3 movement to the left —> the left arrow stop working and it doesn't react anymore

Ok, I just reproduced this myself. Although the NewStuff demo does not have this problem, so currently I have no idea why this is happening.

Aniway maybe all the things might be reorganized a bit, for example in the event we have a certain number of tabs opened we should add a scrollbar after a while .. or even better we should organized the things like the old MUI OWB 1.9 (the old "hack" tabs done by Denill) like adding a small popup that will contain all the tabs opened in excess

The scroll buttons feature a popup menu to select the tab to be made active. I think this is what you want.

comment:6 Changed 5 years ago by Thore Böckelmann

Milestone: MUI 4.0-2014R3
Priority: undecidednormal
Status: newaccepted

comment:7 Changed 5 years ago by Roman Kargin

@samo

Aniway maybe all the things might be reorganized a bit

Just press via right right mouse button over those left/right images.

comment:8 Changed 5 years ago by Samir Hawamdeh

@Thore

Although the NewStuff demo does not have this problem
so currently I have no idea why this is happening.

Yes confirmed, altrough when you have some tabs opened still some flickering effect (later i will open another bug report)

@kas1e

Just press via right right mouse button over those left/right images.

Ops i see it only now !

comment:9 Changed 5 years ago by Thore Böckelmann

Owner: set to Thore Böckelmann
Resolution: fixed
Status: acceptedclosed

In 3241:

  • Title.c, Area.c: raised the default priority of Area.mui's eventhandler by 1. Additionally the eventhandler of Title.mui gets a default priority higher than that of Area.mui. This ensures that both drag&drop and scrolling through all tabs is working correctly for Title.mui. This finally closes #6.

comment:10 Changed 5 years ago by Thore Böckelmann

Release Notes: modified (diff)

comment:11 Changed 4 years ago by Thore Böckelmann

Milestone: MUI 4.0-2014R34.0-2014R3

Milestone renamed

Note: See TracTickets for help on using tickets.