Opened 6 years ago

Closed 6 years ago

Last modified 5 years ago

#55 closed bug (fixed)

MUI Menu

Reported by: Mikhail Malyshev Owned by: Thore Böckelmann
Priority: normal Milestone: 3.9-2014R2
Component: muimaster.library Version: 3.9-2014R1
Severity: minor Keywords:
Cc: OS Platform: AmigaOS3
Blocked By: Blocking:
Release Notes:

Fixed the wrong remapping of the embedded MagicWB menu images.

Description

Colours for dividers and point marks are out of MWB range in menu.
Should use halfshine/halfshadow (greys), currently yellow and green tinting. Used to be fine in older versions of MUI.

Attachments (5)

MUI-MENU-COLOURS-BAD.PNG (25.3 KB) - added by Mikhail Malyshev 6 years ago.
MUI39old-simple-menu.png (11.4 KB) - added by Mikhail Malyshev 6 years ago.
good simple menu
MUI39old-candy-menu.png (30.3 KB) - added by Mikhail Malyshev 6 years ago.
good candy menu
MUI39old-color-menu.png (15.3 KB) - added by Mikhail Malyshev 6 years ago.
good colour menu with adapting colour of dividers
menu24bits.png (15.9 KB) - added by Mikhail Malyshev 6 years ago.

Download all attachments as: .zip

Change History (23)

comment:1 Changed 50 years ago by Mikhail Malyshev

Status: pendingnew

Changed 6 years ago by Mikhail Malyshev

Attachment: MUI-MENU-COLOURS-BAD.PNG added

comment:1 Changed 6 years ago by Thore Böckelmann

Component: Menu.muiPopmenu.mui
Milestone: MUI 3.9-2014R2
Owner: set to Thore Böckelmann
Priority: undecidednormal
Status: newassigned

comment:2 Changed 6 years ago by Thore Böckelmann

Resolution: fixed
Status: assignedclosed

In 3625:

  • Popmenu.c: use the global halfshine and halfshadow pens instead of creating them again with just slightly different colors. This closes #55.

comment:3 Changed 6 years ago by Mikhail Malyshev

Resolution: fixed
Status: closedreopened

Fixed, but not 100%.
The small GFX images like AMIGAkey and BIGDOTS in sub menus
when selected one of the fill colours changes to light green.
According to older MUI versions, MWB and MagicMenu the colour should be the system default blue pen. Please compare to MagicMenu menus, they should be similar.

comment:4 Changed 6 years ago by Thore Böckelmann

Status: reopenedpending

Sigh. You must at least wait until the next nightly build is released which usually happens at 2:00 CET in the morning. Just be a bit patient.

comment:5 Changed 6 years ago by Mikhail Malyshev

My original idea of using halfshine/halfshadow was wrong!
It is true for MWB palette only.
The two colours for the divider need to be generated depending on the colour of the menu background. One slightly lighter, second slightly darker.
The problem is probably in wrong computation of colours in 16 bit modes
since RGB have 5 6 5 bit depth.

Sample code can be obtained from open source MagicMenu code, it will also help implement transparent menus someone asked here.

Open MagicMenu prefs and see see how the design changes when you change the background colour in realtime.

The problem with GREENISH offset for menu bitmap images is still present

comment:6 in reply to:  5 Changed 6 years ago by Thore Böckelmann

Replying to Michael:

The problem with GREENISH offset for menu bitmap images is still present

Then please provide a screenshot with correct colors for comparison.

Changed 6 years ago by Mikhail Malyshev

Attachment: MUI39old-simple-menu.png added

good simple menu

Changed 6 years ago by Mikhail Malyshev

Attachment: MUI39old-candy-menu.png added

good candy menu

Changed 6 years ago by Mikhail Malyshev

Attachment: MUI39old-color-menu.png added

good colour menu with adapting colour of dividers

comment:7 Changed 6 years ago by Mikhail Malyshev


bad colours on divider, and really of on the bitmap dot

good simple menu good
good candy menu good
good colour menu with adapting colour of dividers good, divider colour adapts automatically

comment:8 Changed 6 years ago by Thore Böckelmann

Component: Popmenu.muimuimaster.library
Status: newassigned

comment:9 Changed 6 years ago by Thore Böckelmann

Resolution: fixed
Status: assignedclosed

In 3692:

  • mastergfx.c: fixed a wrong register definition of an internal function to obtain a pen which caused colors with shifted RGB to be allocated. This closes #55.

comment:10 Changed 6 years ago by Mikhail Malyshev

Resolution: fixed
Status: closedreopened

Yes, the bitmaps are ok now.
Now please restore the changes for the menu divider bar. It has to adapt to the colour of the menu and should not be a fixed colour (only true for MWB palette, also the shine pen was set a tone too dark anyway).

comment:11 Changed 6 years ago by Thore Böckelmann

Resolution: fixed
Status: reopenedclosed

In 3702:

  • Popmenu.c: use the calculated halfshine/halfshadow pens for the separator bar on colormapped screens. This finally closes #55.

comment:12 Changed 6 years ago by Thore Böckelmann

Release Notes: modified (diff)

Changed 6 years ago by Mikhail Malyshev

Attachment: menu24bits.png added

comment:13 Changed 6 years ago by Mikhail Malyshev


Works correctly now in 8 bits

But in 16/24 bits the indent divider is fixed to single grey colour!
This is even more evident if menu is some rgb color

comment:14 Changed 6 years ago by Mikhail Malyshev

Resolution: fixed
Status: closedreopened

comment:15 Changed 6 years ago by Thore Böckelmann

Resolution: fixed
Status: reopenedclosed

In 3719:

  • Popmenu.c: allocate the halfshine and halfshadow pens for all kinds of screens. This closes #55.

comment:16 Changed 6 years ago by Mikhail Malyshev

Ok. Seems to work now.

comment:17 Changed 5 years ago by Thore Böckelmann

Milestone: MUI 3.9-2014R23.9-2014R2

Milestone renamed

Note: See TracTickets for help on using tickets.