Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#50 closed enhancement (wontfix)

MUI 3.9 Nightly builds

Reported by: Mikhail Malyshev Owned by:
Priority: normal Milestone: 3.9-2014R2
Component: undefined Version: nightly build
Severity: minor Keywords:
Cc: OS Platform: AmigaOS3
Blocked By: Blocking:
Release Notes:

Description

Please provide nightly builds with stripped debug data.
Currently both archives for AOS3 have full debug included.
Debug is nice for finding out the real bugs, but not good for full time testing and a bit too heavy for the classic.

Change History (3)

comment:1 Changed 5 years ago by Thore Böckelmann

Priority: undecidednormal
Resolution: wontfix
Status: newclosed

I think you are confusing "debug binaries" and "binaries with full debug infomation".

The first are specially built binaries which output debug messages while executing the normal code. The additional output can be captured with a second computer connected to the serial line or local with a tool like Sashimi. The execution is slowed down by the additional code.

The latter are normal binaries without any further code or any other abilities except special hunks which tell tools like a debugger or gccfindhit which machine instruction was generated by which line of code. These hunks are usually quite big but they are not loaded into memory when starting a program. They are completely skipped. The execution is as fast as for the same stripped binary without the debug hunks. Unfortunately running a binary without the debug hunks will produce different hits than a binary with debug hunks due to the different offsets within the executable file. And this makes it impossible to search for bugs in a binary with debug hunks using the information from a crash log done with a binary without the debug hunks.

Since MUI 3.9 is a beta release until further notice to be able to catch as many bugs as possible until the next official release there will be no nightly builds without debug information. The reason is that people will download the smaller archive and we are not able to find the cause of the crashes they are experiencing.

comment:2 Changed 5 years ago by Thore Böckelmann

Milestone: MUI 3.9-2014R2

comment:3 Changed 4 years ago by Thore Böckelmann

Milestone: MUI 3.9-2014R23.9-2014R2

Milestone renamed

Note: See TracTickets for help on using tickets.