Opened 4 weeks ago

Closed 3 weeks ago

#453 closed bug (fixed)

Guigfx.mcc native crash with iGame 2.0 Beta 7

Reported by: Samir Hawamdeh Owned by: Thore Böckelmann
Priority: normal Milestone: 5.0-2020R2
Component: Guigfx.mcc Version: 5.0-nightly build
Severity: minor Keywords:
Cc: OS Platform: AmigaOS4
Blocked By: Blocking:
Release Notes:

Description

Just tried the latest iGame 2.0 Beta 7 from GitHub (OS4 binary) and got a crash that point to Guigfx.mcc
Did not tested yet if that specific beta 7 will work with the "original" version of Guigfx.mcc, but as the old version of iGame worked, it may possible that the issue could be related to the newer native version of Guigfx.mcc

Attachments (8)

Crashlog_iGame.OS4_2020-09-26_21-10-18.txt (24.2 KB) - added by Samir Hawamdeh 4 weeks ago.
Guigfx_debug_os3.lha (78.0 KB) - added by Thore Böckelmann 3 weeks ago.
debug version of Guigfx.mcc for AmigaOS3
Guigfx_debug_os4.lha (121.5 KB) - added by Thore Böckelmann 3 weeks ago.
debug version of Guigfx.mcc for AmigaOS4
Crashlog_iGame.OS4_2020-09-28_18-55-13.txt (24.2 KB) - added by Samir Hawamdeh 3 weeks ago.
Guigfx debug for OS4
Guigfx_21.2_os3.lha (72.5 KB) - added by Thore Böckelmann 3 weeks ago.
fixed Guigfx.mcc 21.2 for AmigaOS3
Guigfx_debug_os4.2.lha (121.5 KB) - added by Thore Böckelmann 3 weeks ago.
fixed Guigfx.mcc 21.2 for AmigaOS4
Crashlog_iGame.OS4_2020-09-29_18-46-08.txt (25.9 KB) - added by Samir Hawamdeh 3 weeks ago.
Crashlog_iGame_2020-09-30_02-25-41.txt (24.3 KB) - added by Samir Hawamdeh 3 weeks ago.

Download all attachments as: .zip

Change History (17)

Changed 4 weeks ago by Samir Hawamdeh

comment:1 Changed 3 weeks ago by Thore Böckelmann

Component: undefinedGuigfx.mcc
Milestone: future release5.0-2020R2
Owner: set to Thore Böckelmann
Priority: undecidednormal
Status: newassigned

So far I am not able to reproduce a crash on AmigaOS3, haven't tried AmigaOS4 yet. Although I can confirm that there are certain MungWall hits being reported about a zero sized AllocMem() call. But that happens in render.library, which Guigfx.mcc does not use directly. But even with that MungWall hit the images are displayed correctly.

All I can do for the moment is to provide a full debug version of Guigfx.mcc with additional debug output during doSet(). Please capture a debug log with that version. No special settings are required.

Changed 3 weeks ago by Thore Böckelmann

Attachment: Guigfx_debug_os3.lha added

debug version of Guigfx.mcc for AmigaOS3

Changed 3 weeks ago by Thore Böckelmann

Attachment: Guigfx_debug_os4.lha added

debug version of Guigfx.mcc for AmigaOS4

comment:2 Changed 3 weeks ago by Samir Hawamdeh

Ok, installed Guigfx debug for OS4 and restarted again the native iGame.os4
Attached the new crashlog

Changed 3 weeks ago by Samir Hawamdeh

Guigfx debug for OS4

comment:3 Changed 3 weeks ago by Thore Böckelmann

Ok, I finally got it. Settings the image's quality during OM_NEW caused the crash. This is something that is different from the former implementation, which unfortunately did not allow to change the image's quality settings on the fly

comment:4 Changed 3 weeks ago by Thore Böckelmann

Resolution: fixed
Status: assignedclosed

In 6666:

  • mcc/Guigfx.c: do not access pointers which are still invalid during OM_NEW. This closes #453.

Changed 3 weeks ago by Thore Böckelmann

Attachment: Guigfx_21.2_os3.lha added

fixed Guigfx.mcc 21.2 for AmigaOS3

Changed 3 weeks ago by Thore Böckelmann

Attachment: Guigfx_debug_os4.2.lha added

fixed Guigfx.mcc 21.2 for AmigaOS4

comment:5 Changed 3 weeks ago by Samir Hawamdeh

Mmm installed but still having crash

Changed 3 weeks ago by Samir Hawamdeh

comment:6 Changed 3 weeks ago by Thore Böckelmann

The crashlog clearly states you are still using Guigfx.mcc 21.1, but 21.2 is the fixed version.

comment:7 Changed 3 weeks ago by Samir Hawamdeh

Ops, yep you are right … however the os4 binary you linked above still was 21,1 !
… only the 68k one seems really updated at 21.2 ..

Aniway, i tried the 68k binary now .. but again i got a crash .. just this time seems a different kind of…
See crashlog attached

Changed 3 weeks ago by Samir Hawamdeh

comment:8 Changed 3 weeks ago by Thore Böckelmann

Resolution: fixed
Status: closedreopened

Too bad… I really thought I rebuilt both versions. Sorry, my fault.

I suggest to retry with the current nightly build as well. This one definitely includes the latest version for all systems. Using the native version is better, because the stack trace will contain valid file names and line numbers then.

comment:9 Changed 3 weeks ago by Thore Böckelmann

Resolution: fixed
Status: reopenedclosed

In 6669:

  • mcc/Guigfx.c: GetNewHandle() must be called during MUIM_Show instead of during MUIM_Setup, because otherwise the _rp() pointer is not valid yet. This closes #453 again.
Note: See TracTickets for help on using tickets.