Opened 4 weeks ago

Closed 3 weeks ago

#448 closed bug (fixed)

Radio items don't work inside context menu

Reported by: Andreas Falkenhahn Owned by: Thore Böckelmann
Priority: normal Milestone: 5.0-2020R2
Component: Popmenu.mui Version: 5.0-2020R1
Severity: minor Keywords:
Cc: OS Platform: All
Blocked By: Blocking:
Release Notes:

Description

Check out the attached example. Open the context menu and select the item named "Choose me". Open the context menu again. You'll see that nothing has changed. Normally, "Choose me" should be selected now and "Test item" should be unselected.

Attachments (1)

main.c (4.1 KB) - added by Andreas Falkenhahn 4 weeks ago.

Download all attachments as: .zip

Change History (3)

Changed 4 weeks ago by Andreas Falkenhahn

Attachment: main.c added

comment:1 Changed 3 weeks ago by Thore Böckelmann

Component: Menuitem.muiPopmenu.mui
Milestone: future release5.0-2020R2
Owner: set to Thore Böckelmann
Priority: undecidednormal
Status: newassigned

comment:2 Changed 3 weeks ago by Thore Böckelmann

Resolution: fixed
Status: assignedclosed

In 6605:

  • Popmenu.c: the selection state of radio items was immediately toggled again and thus made it impossible to use such items as intended. The additional flag toggling simply had to be removed. This closes #448.
Note: See TracTickets for help on using tickets.