Opened 4 weeks ago

Closed 4 weeks ago

#447 closed bug (fixed)

r6601 PSI font requester font styles strange/missing styles

Reported by: Javier de las Rivas Owned by: Thore Böckelmann
Priority: normal Milestone: 5.0-2020R2
Component: Fontpanel.mui Version: 5.0-nightly build
Severity: minor Keywords:
Cc: OS Platform: AmigaOS4
Blocked By: Blocking:
Release Notes:

Description

Summary

Just found it with r6601, opening PSI window and MUI font requester missing some styles (shadow, outline and normal)

Steps to reproduce

1.Open MUI main and go to Screen/PSI option
2.Click on font gadget to get mui font requester

Expected results

Actual results

Regression

Notes

Attachments (1)

sgrab001.png (63.8 KB) - added by Javier de las Rivas 4 weeks ago.
mui psi font requester

Download all attachments as: .zip

Change History (3)

Changed 4 weeks ago by Javier de las Rivas

Attachment: sgrab001.png added

mui psi font requester

comment:1 Changed 4 weeks ago by Thore Böckelmann

Component: undefinedFontpanel.mui
Milestone: future release5.0-2020R2
Owner: set to Thore Böckelmann
Priority: undecidednormal
Status: newassigned

That is intentional. You select the screen font there and that font is used by operating system, not by MUI. But the operating system (graphics.library, intuition.library) does not support the extended MUI font styles. Hence they are omitted from that requester. Only normal MUI objects inside a MUI application can make use of these extended styles, nothing else.

If there is a bug somewhere, then it would be the visibility of the "Text" and "Outline" buttons, because these two colors cannot be used by the operation system either.

comment:2 Changed 4 weeks ago by Thore Böckelmann

Resolution: fixed
Status: assignedclosed

In 6602:

  • Pubscreenadjust.c: hide the "Text" and "Outline" color buttons in case a font for system use is to be selected. AmigaOS cannot handle the extended font styles of MUI. This closes #447.
Note: See TracTickets for help on using tickets.