Opened 6 months ago

Closed 6 months ago

Last modified 6 months ago

#434 closed bug (invalid)

ISO 8859-1 characters not drawn correctly on OS4

Reported by: Andreas Falkenhahn Owned by:
Priority: normal Milestone: 5.0-2020R1
Component: Text.mui Version: 5.0-2019R4
Severity: minor Keywords:
Cc: OS Platform: AmigaOS4
Blocked By: Blocking:
Release Notes:

Description

When the MUI system font is set to golded.font size 13, the $a6 (¦) character isn't drawn correctly on OS4. It's drawn as "ÿ" on OS4. On OS3 everything is fine.

I'm attaching 4 things:

1) Demo program
2) Screenshot of program on OS4 (bad)
3) Screenshot of program on OS3 (good)
4) Golded.font

Attachments (4)

main.c (1.8 KB) - added by Andreas Falkenhahn 6 months ago.
os3.png (4.1 KB) - added by Andreas Falkenhahn 6 months ago.
os4.png (7.3 KB) - added by Andreas Falkenhahn 6 months ago.
golded.lha (7.2 KB) - added by Andreas Falkenhahn 6 months ago.

Download all attachments as: .zip

Change History (8)

Changed 6 months ago by Andreas Falkenhahn

Attachment: main.c added

Changed 6 months ago by Andreas Falkenhahn

Attachment: os3.png added

Changed 6 months ago by Andreas Falkenhahn

Attachment: os4.png added

Changed 6 months ago by Andreas Falkenhahn

Attachment: golded.lha added

comment:1 Changed 6 months ago by Thore Böckelmann

I can confirm the different output between both systems. But if you want to get a pipe character then 0x7c would be the correct choice. Anything beyond 0x7f is non-ASCII and may depend on fonts and charset interpretation.

The only difference I see with the configured screen font is the output of a capital 'S' with an upside down caret on top. But on the other hand this matches the output of the CharMap tool (http://aminet.net/text/font/CharMap.lha). On AmigaOS4 it shows me exactly the same S plus caret as MUI does. However, on AmigaOS3 I see the pipe character (two vertical lines). As I see it MUI does nothing wrong and shows exactly the desired character. This does not really supprise me, because neither Text class nor MUI's text engine does further interpretation or processing of the text unless explicitly instructed to do so. The text is displayed 'as is'.

But somehow I cannot get OS4 to use your supplied golded font…

comment:2 Changed 6 months ago by Andreas Falkenhahn

Actually, you don't even need to use that golded font. Just try the standard helvetica font. On OS4 you get that weird capital "S" with an upside down caret whereas on OS3 you get the correct character.

Btw, I know that everything above 0x7f is non-ASCII but since the system is configured to use ISO 8859-1 characters above 0x7f should be rendered correctly (as they are on OS3 and MorphOS). Strangely, äöüß are rendered correctly so it's not a general problem but seems to be specific to that character at 0xa6.

comment:3 Changed 6 months ago by Thore Böckelmann

Milestone: future release5.0-2020R1
Priority: undecidednormal
Resolution: invalid
Status: newclosed

You can use any font and any application to get this - unfortunately odd (or wrong) - behaviour. It is definitely not MUI's fault, because MUI based applications display the same unwanted character as non-MUI based application. The fault is located somewhere in AmigaOS4.

comment:4 Changed 6 months ago by Andreas Falkenhahn

True. I've now posted about it in the OS4 forums: https://forum.hyperion-entertainment.com/viewtopic.php?f=26&t=4450

Note: See TracTickets for help on using tickets.