Opened 11 months ago

Closed 9 months ago

#421 closed enhancement (wontfix)

Changing name of the Clock demo

Reported by: Samir Hawamdeh Owned by:
Priority: normal Milestone: 5.0-2020R1
Component: demos Version: 5.0-nightly build
Severity: minor Keywords:
Cc: OS Platform: All
Blocked By: Blocking:
Release Notes:

Description

Problem

By accident the Clock demo in "Demos" folder of MUI share the same name of the Clock utility of the Enancher Package of AmigaOS4

Analysis

In case you have, atleast once lanched the Clock demo of MUI, then anytime you strat the Updater program of the Enancher Package, the name version of this MUI demo will conflct with the Clock utility of the Enancher … this prevent you to check and download correctly the Clock utility using Updater
When you open the Updater

Enhancement recommendation

Well, perhaps changing the name of this demo from "Clock" to "MUI Clock" or something similar could help

Change History (3)

comment:1 Changed 10 months ago by Thore Böckelmann

There might always be a collision with similar or the same application names. I'd suggest to adapt the logic of the Updater instead of having to rename arbitrary foreign applications.

Why does the Updater search in paths of foreign applications at all? MUI is no part of the Enhancer package. So why is its folder taken care of?

comment:2 Changed 10 months ago by Samir Hawamdeh

I don't know exactly how it could be done, i mean .. there is no a fixed path (apart for the obvious classes, libraries and drivers) .. but regard these other components (like Clock) you can, eventually install them everywhere you like most … so how can be possible for Updater to check exactly what component is strictly related to the Enancher Package or not ?
That's why Updater check for the name of the program i think … now as yours is merely a demo apps, maybe is your component that might be renamed in order to avoid eventual conflicts .. atleast this is what i understand from the situation ..

comment:3 Changed 9 months ago by Thore Böckelmann

Component: Clock.mccdemos
Milestone: future release5.0-2020R1
Priority: undecidednormal
Resolution: wontfix
Status: newclosed

Having thought about this issue once more it remembered that it seems to be caused by the APPDIR: feature of AmigaOS4. If you run an application with a specific name for the first time its full path and will be remembered by the APPDIR: device. The next time you just run "Clock" from a shell APPDIR: will be check first and if an entry exists this will be used instead of searching the standard command search path.

So, any application named 'Clock' will break the update check of the Enhancer Package, no matter where it stems from. You cannot expect any developer to rename their application just because they might perhaps collide with an application of the Enhancer Package. A better approach would be to change the Enhancer Package's update mechanism to really check their own applications instead of random application which might have been run once on a system.

I don't know how the Enhancer Package installs its applications or whether the user has the choice of the destination directory. But simply assuming that APPDIR: will point to the correct location is a bad idea, especially if a fixed installtion directory is set. In case the user can choose a directory himself this choice should be remembered for further updates.

Note: See TracTickets for help on using tickets.