Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#42 closed bug (fixed)

8-bit screens / low colour / low free pens situations

Reported by: mm@… Owned by: Thore Böckelmann
Priority: normal Milestone: 3.9-2014R2
Component: Pixmap.mui Version: 3.9-2014R1
Severity: minor Keywords:
Cc: OS Platform: AmigaOS3
Blocked By: Blocking:
Release Notes:

Description

Summary

For classic 8c MWB need to provide fall back images and some prefs settings (for colour chooser window)

Trashed icons in prefs lists, even in 256c modes

Inability to set/pick colour, no RGB sliders (eg. like MUI 3.8 or older 3.9)

Attachments (3)

MUI-5-lowcolourprob.png (36.8 KB) - added by Mikhail Malyshev 5 years ago.
Low colour example
MUI39-OLD.PNG (145.1 KB) - added by Mikhail Malyshev 5 years ago.
Older MUI 3.9 colour setting (ideal for lower end machines)
MUI-COLOUR-SETTINGS-256c.PNG (48.1 KB) - added by Mikhail Malyshev 5 years ago.
Current colour settings, unusable in none true colour modes

Download all attachments as: .zip

Change History (11)

comment:1 Changed 5 years ago by Thore Böckelmann

First of all, do NOT mix up several issues in one ticket.

If you talk about "some" images then you should clearly state which images exactly you are talking about. This important bit of information is missing.

Which prefs icons are trashed?

Where exactly are you unable to pick a color?

Face it, just like #40 this ticket is missing the basic information how to reproduce an issue. There are no screenshots to proove or describe the issues. There is nothing. This is NOT how bug are to be reported.

Changed 5 years ago by Mikhail Malyshev

Attachment: MUI-5-lowcolourprob.png added

Low colour example

comment:2 Changed 5 years ago by Mikhail Malyshev

Improving ;-)

Changed 5 years ago by Mikhail Malyshev

Attachment: MUI39-OLD.PNG added

Older MUI 3.9 colour setting (ideal for lower end machines)

Changed 5 years ago by Mikhail Malyshev

Current colour settings, unusable in none true colour modes

comment:3 Changed 5 years ago by Thore Böckelmann

Please do not use the name "MUI 3.9" if you are in fact talking about MUI 3.8. This is really confusing and does not help anybody. Your first screenshot was definitely done with MUI 3.8, not with MUI 3.9.

comment:4 Changed 5 years ago by Mikhail Malyshev

If you look closely MUI 3.8 does not have the External classes prefs button at top left corner. I am using different builds of 3.9 for the last 10 years or more.

comment:5 Changed 5 years ago by Mikhail Malyshev

MUI-5-lowcolourprob.png - this file show trashed images,
it looks that only the colourful images are effected.
I suspect they are stored in chunky format.
While older MWB type images (some external classes) are displayed correctly under all conditions (maybe because they are planner?).

comment:6 Changed 5 years ago by Thore Böckelmann

Component: undefinedPixmap.mui
Milestone: MUI 3.9-2014R2
Owner: set to Thore Böckelmann
Priority: undecidednormal
Status: newassigned

comment:7 Changed 5 years ago by Thore Böckelmann

Resolution: fixed
Status: assignedclosed

In 3637:

  • Pixmap.c: use graphics/WritePixelArray8() to convert the dithered chunky data into a bitmap in case CyberGraphics is not available. This closes #42 and closes #49.

comment:8 Changed 5 years ago by Thore Böckelmann

Milestone: MUI 3.9-2014R23.9-2014R2

Milestone renamed

Note: See TracTickets for help on using tickets.