Opened 4 weeks ago

Last modified 4 weeks ago

#419 pending bug

Is there a version that will support 16 bit colours on AmigaOS 3.x

Reported by: pgergen@… Owned by:
Priority: undecided Milestone: 5.0-2019R4
Component: undefined Version: 5.0-2019R3
Severity: minor Keywords:
Cc: OS Platform: AmigaOS3
Blocked By: Blocking:
Release Notes:

Description

Summary

After installing MUI 5.0R3 on my A2000 Vampire edition, I can only get MUI to operated flawlessly on 32 bit mode - but not 16 bit mode.

Steps to reproduce

  1. In 32 bit mode MUI 5.0R3 works flawlessly
  2. In 16 bit mode MUI 5.0R3 crashes very shortly after accessing any app that uses MUI.

Expected results

MUI would work flawlessly in 16 bit mode

Actual results

Cannot use 8 or 16 bit colour modes on the Amiga.

Regression

Maybe use MUI 3.8 ?

Notes

Is there a way to use less that the 24 bit colour scheme specified ?

Thank you
Peta Michaela Gergen
pgergen@…

Change History (1)

comment:1 Changed 4 weeks ago by Thore Böckelmann

Milestone: future release5.0-2019R4
Status: newpending

From the sight of an application using graphics.library or cybergraphics.library to perform any graphical modifications on the screen there is absolutely no difference between 16bit, 24bit or 32bit screenmodes. All the raw graphic data are prepared as full 32bit ARGB values and passed to the system. However, the system (Cybergraphics or Picasso96) is then responsible to convert these data to match the actual screenmode to be drawn correctly. But the is beyond the scope of any application.

If 16bit screenmodes cause MUI to crash but 32bit screenmodes work, then this is not a bug in MUI. Du to limited graphic memory I have been using MUI with 16bit screenmodes for a very long time without any instabilities.

Furthermore I don't know how compatible a Vampire board might be. Maybe there are issues as well.

Note: See TracTickets for help on using tickets.