Opened 5 weeks ago

Closed 5 weeks ago

Last modified 5 weeks ago

#408 closed bug (fixed)

Garbage in mui settings when press RMB right over bound-lines (see screesnhot)

Reported by: Roman Kargin Owned by: Thore Böckelmann
Priority: normal Milestone: 5.0-2019R2
Component: Settings.mui Version: 5.0-2019R1
Severity: minor Keywords:
Cc: OS Platform: AmigaOS4
Blocked By: Blocking:
Release Notes:

Description

Found today that when i press RMB in any mui settings window when cursor is exactly on the place where vertical line is drawn (see on screenshot i point out by red mark where cursor stays when i press RMB), then in the title of the dropdown menu, we have some random-sharacters.

All tests done over MUI-5.0-2019R1-os4.lha

Attachments (1)

menus_garbage.jpg (153.9 KB) - added by Roman Kargin 5 weeks ago.
example

Download all attachments as: .zip

Change History (4)

Changed 5 weeks ago by Roman Kargin

Attachment: menus_garbage.jpg added

example

comment:1 Changed 5 weeks ago by Thore Böckelmann

Component: undefinedSettings.mui
Milestone: future release5.0-2019R2
OS Platform: undefinedAmigaOS4
Owner: set to Thore Böckelmann
Priority: undecidednormal
Status: newassigned

comment:2 Changed 5 weeks ago by Thore Böckelmann

Resolution: fixed
Status: assignedclosed

In 6440:

  • Settings.c: trying to open the context menu on the frame of the settings page caused an invalid title due to an invalid determined page. Now the frame area is ignored for the context menu. This closes #408.

comment:3 Changed 5 weeks ago by Thore Böckelmann

BTW: nice to see you are working on a port of Vim/MUI ;)

Note: See TracTickets for help on using tickets.