Opened 7 months ago

Closed 6 weeks ago

#406 closed bug (worksforme)

SysMon crash at exit

Reported by: Samir Hawamdeh Owned by: Thore Böckelmann
Priority: undecided Milestone: 5.0-2019R3
Component: muimaster.library Version: 5.0-nightly build
Severity: minor Keywords:
Cc: Guillaume Boesel OS Platform: AmigaOS4
Blocked By: Blocking:
Release Notes:

Description

More than once I got a crash while trying to close SysMon 6.3 (just pressing the close gadget and nothing else)
Not sure if could be related to MUI or SysMon directly, but maybe it worth to report here aswell

Tested with:

SysMon 6.3 (from Guillame Boesel package)
MUI 21.17
muimaster.library 21.163

Attachments (1)

Crashlog_SysMon_2019-04-01_14-58-07.txt (33.4 KB) - added by Samir Hawamdeh 7 months ago.

Download all attachments as: .zip

Change History (13)

Changed 7 months ago by Samir Hawamdeh

comment:1 Changed 7 months ago by Thore Böckelmann

Could you please try to reproduce this crash using the debug version of muimaster.library while producing an OBJECT debug log?

Since this issue seems to happen for SysMon only I suppose there is no general fault in MUI, but a bug in SysMon. Maybe an object is disposed twice: once by disposing in explicitly via MUI_DisposeObject() and a second time implicitly because Group class disposes the object as being the owner of the object.

comment:2 Changed 7 months ago by Thore Böckelmann

Milestone: future release5.0-2019R1
Owner: set to Thore Böckelmann
Status: newassigned

comment:3 Changed 7 months ago by Thore Böckelmann

Milestone: 5.0-2019R15.0-2019R2

comment:4 Changed 6 months ago by Thore Böckelmann

Cc: Guillaume Boesel added

Do you have any interest in resolving this issue?

comment:5 Changed 6 months ago by Guillaume Boesel

Just installed latest MUI (muimaster.library 21.167) and rebooted.
Started SysMon 6.4 from CLI or WB, opened all the tabs and closing from Quit button or Close gadget.
No crash encountered.
Samir, could you try with the latest MUI (MUI-5.0-2019R1-os4.lha) ?

comment:6 Changed 6 months ago by Guillaume Boesel

and don't you have SysMon 6.4 instead of 6.3 ?

comment:7 Changed 6 months ago by Samir Hawamdeh

Actually I have version 6.3 of SysMon … (and of course latest MUI5 R1 installed)
I wasn't able to replicate the crash again, however i noted a curious behaviour, if i leave opened SysMon staying in that "tab" and waiting a couple of minutes without doing anything, then when i click into the close gadget the program does not quit … (o better say, at the end it quit but i need to wait minutes!)

comment:8 Changed 3 months ago by Thore Böckelmann

Milestone: 5.0-2019R25.0-2019R3

Any news on this issue?

comment:9 Changed 3 months ago by Samir Hawamdeh

I'm still using version 6.3 as Guillaume did not send me the new binary yet
However lately i did not have crashes, so don't know what to think

comment:10 Changed 6 weeks ago by Thore Böckelmann

Still no news?

comment:11 Changed 6 weeks ago by Samir Hawamdeh

Mmm unfortunely Guillaume did not send me anything new, however further test i've done was not able to reproduce the issue anymore .. perhaps you can close the ticket.. eventually we can reopen it later

comment:12 Changed 6 weeks ago by Thore Böckelmann

Component: undefinedmuimaster.library
Resolution: worksforme
Status: assignedclosed
Note: See TracTickets for help on using tickets.