Opened 9 months ago

Closed 9 months ago

#402 closed bug (fixed)

5.0 2018R3 MUI preferences freeze in OS 3.1

Reported by: robikz Owned by: Thore Böckelmann
Priority: normal Milestone: 5.0-2019R1
Component: muimaster.library Version: 5.0-2018R3
Severity: minor Keywords:
Cc: OS Platform: AmigaOS3
Blocked By: Blocking:
Release Notes:

Description

Summary

Opening the preferences tool in release 5.0 2018R3 for OS 3.0 causes the program to hang up. Workbench on my Amiga 1200 can recover from that by popping up the suspend/reboot dialog box. WinUAE displays HALT3 on its status bar and freezes altogether.

5.0 2018R2 behaves correctly and doesn't freeze.

Steps to reproduce

  1. Install MUI from archive https://muidev.de/download/MUI%205.0%20-%20Release/MUI-5.0-2018R3-os3.lha
  2. Open the drawer where you installed MUI to.
  3. Double-click on the MUI tool to run it.

Expected results

Don't freeze.

Actual results

MUI preferences window appears and the program/system subsequently freezes.

Notes

WinUAE config:

  • Kickstart 3.1 rev. 40.68
  • Workbench 3.1 rev. 40.42
  • 68020, JIT, Fastest Possible
  • AGA chipset
  • 2MB CHIP, 64MB Z3 FAST

Amiga 1200 setup:

  • Kickstart/Workbench as above
  • 68030
  • 2MB CHIP, 32MB Z3 FAST

Change History (11)

comment:1 Changed 9 months ago by Thore Böckelmann

5.0-2018R4 has just been released. Please test again with that release and report whether it works or not.

comment:2 Changed 9 months ago by Thore Böckelmann

Reporter: changed from zalewapl@… to robikz

comment:3 Changed 9 months ago by Thore Böckelmann

Since 2018R2 does work for you and the problems start with 2018R3 it should be quite easy to find out the code change which introduced this issue for you.

This means I will create certain special builds from all changes between 2018R2 and 2018R3 and you will have to test them and tell me whether the issue occurs or not.

There have been done approx 60 commits between the two releases. Some of them cover changes of the translations. So I propose that approx. 5 test versions should be sufficient to find out the guilty commit.

Here is the link to the first version to be tested:
r6327

Make sure to install all files, classes and libraries from this archive. Then reboot and check whether the issue occurs or not.

comment:4 Changed 9 months ago by robikz

r6327 doesn't crash in WinUAE when I open the prefs.

In the email you asked me if I have any experience with Amiga debugging tools. Sadly, I have none. I might learn them as it sounds interesting, but let's continue with trying to bisect the breaking commit for now.

Do you have trouble reproducing the problem by yourself given the configuration I posted?

comment:5 Changed 9 months ago by Thore Böckelmann

Ok. If I am not guessing completely wrong, then ​r6337 does work and problems start with ​r6341. Please try there two builds. The issue must be related to the implementation of transparent text for AmigaOS3.

Regarding the reproducibility, my virtual Amiga setup is based on AmiKit with all the bells and whistles that AmiKit offers. Degrading it to a plain AmigaOS 3.1 setup is not as easy as it may sound. That's why it is not so easily possible for me to reproduce this issue myself.

Last edited 9 months ago by Thore Böckelmann (previous) (diff)

comment:6 Changed 9 months ago by Thore Böckelmann

What kind of screenmode are you using for the Workbench? Do you have CybergraphX or Picasso96 running? Or are you using plain old native 8bit modes?

comment:7 Changed 9 months ago by robikz

It is indeed as you expected. r6337 works and r6341 crashes. I am using the classic "PAL:High Res" screen mode, nothing fancy.

I also guess I'm lucky to possess the classic Kickstart ROM and WB 3.1 ADFs.

comment:8 Changed 9 months ago by Thore Böckelmann

I think I found the reason for the crash. Most probably a check for truecolor screens was missing and hence MUI tries to use a function of cybergraphics.library which of course must fail, as this library is not available on your system.

Please try this new test build of r6341 with that additional check.

comment:9 Changed 9 months ago by robikz

Aye, I tested in WinUAE and there's no freezing up anymore.

comment:10 Changed 9 months ago by Thore Böckelmann

Component: MUI prefs applicationmuimaster.library
Milestone: future release5.0-2019R1
Owner: set to Thore Böckelmann
Priority: undecidednormal
Status: newassigned

comment:11 Changed 9 months ago by Thore Böckelmann

Resolution: fixed
Status: assignedclosed

In 6427:

  • mastertext.c: added a missing check to avoid using truecolor related functions on colormapped screens, as this will cause crashes on systems without and truecolor capability at all. This closes #402.
Note: See TracTickets for help on using tickets.