Opened 2 years ago

Closed 4 months ago

#401 closed bug (worksforme)

Crash when closing tab (Odyssey)

Reported by: Samir Hawamdeh Owned by:
Priority: normal Milestone: 5.0-2020R2
Component: undefined Version: 5.0-nightly build
Severity: minor Keywords:
Cc: OS Platform: AmigaOS4
Blocked By: Blocking:
Release Notes:

Description

Sometimes i got sporadic crash on Odyssey, this time when i close a tab
Problem seems pointed to certain MUI component so i've attached a crashlog

I'm using the latest MUI5 nightly

Attachments (1)

Crashlog_Odyssey_2018-12-19_02-50-22.txt (28.8 KB) - added by Samir Hawamdeh 2 years ago.

Download all attachments as: .zip

Change History (9)

Changed 2 years ago by Samir Hawamdeh

comment:1 Changed 2 years ago by Samir Hawamdeh

Mmm i think to have understood where exactly the problem is …
It happen when you "play" with the URL bar of Odyssey … to reproduce it just click into the URL bar .. then with the mouse (or even using the keyboard) try to select an URL

Most of the time the URL is correctly selected without crash instantanely, but it could crash also in case you start typing something (or typing something in order to modify an already selected address)

comment:2 Changed 23 months ago by Thore Böckelmann

Sorry for the long delay. I didn't notice there was a new ticket.

The crash happens in Odyssey, not in MUI. Hence there is nothing I can do against this crash, because Odyssey's implementation of MUIM_List_Display operates on its own internal data. MUI has absolutely no idea of how this data is structured. MUI will use the generated strings only, but not their source data.

However, the code in the github repository looks quite sane and does length limited string operations only. But since I cannot derive the exact position of the crash it might happen anywhere in the function, but definitely not in MUI's own code.

comment:3 Changed 5 months ago by Thore Böckelmann

You might want to try to reproduce this issue using the latest debug binaries attached to #428. Perhaps we get some new ideas then. No special setting for ENV:muidebug required for the moment regarding this issue.

comment:4 Changed 5 months ago by Thore Böckelmann

Bump! Samir, any news?

comment:5 Changed 5 months ago by Samir Hawamdeh

Mmmm hard to say .. i will try some stressing test using the latest nightly build

comment:6 Changed 4 months ago by Thore Böckelmann

Did your tests reveal anything new?

comment:7 Changed 4 months ago by Samir Hawamdeh

Did not reproduced anymore, you can probably close the ticket ;-)
Eventually, we can always resurrect it later, if similar problem will happens again

comment:8 Changed 4 months ago by Thore Böckelmann

Milestone: future release5.0-2020R2
Priority: undecidednormal
Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.