Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#4 closed bug (fixed)

dragging of quick-link buttons in Odyssey leads to color garbage and empty dragged data

Reported by: Roman Kargin Owned by: Thore Böckelmann
Priority: normal Milestone: 4.0-2014R3
Component: Area.mui Version: 4.0-2014R2
Severity: minor Keywords:
Cc: OS Platform: AmigaOS4
Blocked By: Blocking:
Release Notes:

Fixed the garbled drag image for groups.

Description

Summary

If we have any quick-link button done from bookmarks , and then want to try to d&d it, then original button color garbaged, as well, as dragged item are empty (while should be the same of content as button itself). Not sure if it can be reproduced with default os4 theme, but can be with ferox (as it have different coloring for buttons).

Steps to reproduce

  1. run odyssey with having one or more quick-links buttons done from bookmarks
  2. try to drag any of them.

Expected results

Color or original button should stays the same, and dragget item should have same content as original item.

I also attach 2 files, to show how it looks like on os4 and mos.

Attachments (2)

drag_quick_button_os4.jpg (229.9 KB) - added by Roman Kargin 5 years ago.
current look on os4
drag_quick_button_mos.jpg (165.8 KB) - added by Roman Kargin 5 years ago.
current look on mos

Download all attachments as: .zip

Change History (7)

Changed 5 years ago by Roman Kargin

Attachment: drag_quick_button_os4.jpg added

current look on os4

Changed 5 years ago by Roman Kargin

Attachment: drag_quick_button_mos.jpg added

current look on mos

comment:1 Changed 5 years ago by Thore Böckelmann

Component: undefinedArea.mui
Milestone: MUI 4.0-2014R3
Priority: undecidednormal
Status: newaccepted

I can reproduce this, but I have no idea why the rendering fails. There is no special implementation of MUIM_CreateDragImage for the quick link button class so the default method will be used. And that works in all other cases as can easily be seen with any other application.

comment:2 Changed 5 years ago by Thore Böckelmann

Owner: set to Thore Böckelmann
Resolution: fixed
Status: acceptedclosed

In 3215:

  • Area.c: fixed the garbled drag image for groups. This closes #4.

comment:3 Changed 5 years ago by Thore Böckelmann

In 3216:

Merged revision(s) 3215 from trunk/mui4x:

  • Area.c: fixed the garbled drag image for groups. This closes #4.

……..

comment:4 Changed 5 years ago by Thore Böckelmann

Release Notes: modified (diff)

comment:5 Changed 4 years ago by Thore Böckelmann

Milestone: MUI 4.0-2014R34.0-2014R3

Milestone renamed

Note: See TracTickets for help on using tickets.