Opened 4 weeks ago

Closed 2 weeks ago

#394 closed bug (fixed)

New screens crashes

Reported by: walkero Owned by: Thore Böckelmann
Priority: normal Milestone: 5.0-2018R4
Component: String.mui Version: 5.0-2018R3
Severity: minor Keywords:
Cc: OS Platform: AmigaOS4
Blocked By: Blocking:
Release Notes:

Description (last modified by Thore Böckelmann)

== Summary ==
With the latest version I am experiencing a lot of crashes when I try to open new screens with various programs, like Odyssey, AmIRC and YAM. The crashes happen if I choose to move to a new screen or if I create a new screen from the MUI preferences.

Tried the above with the MUI preferences window, to move it to other screens, but there where no crashes.

Steps to reproduce

  1. Open Odyssey / Yam / AmIRC on Workbench
  2. From the window menu button try to move them to a new screen

Expected results

To move the app to a new screen

Actual results

Crash and freeze of the whole system

Regression

Notes

Rolled back to 5.0-v2018R2 with which I don't have those crashes.

Attachments (1)

odyssey_mui_crash.log (15.9 KB) - added by walkero 3 weeks ago.
Serial log from Odyssey crashing on opening to it's own screen

Download all attachments as: .zip

Change History (9)

comment:1 Changed 4 weeks ago by Thore Böckelmann

Description: modified (diff)
Reporter: changed from walkero@… to walkero

Have you tried the recent nightly builds already? A stupid but serious bug has been fixed recently which possibly could be responsible for this issue as well.

Changed 3 weeks ago by walkero

Attachment: odyssey_mui_crash.log added

Serial log from Odyssey crashing on opening to it's own screen

comment:2 Changed 3 weeks ago by walkero

Unfortunately, tried with nightly build MUI-5.0-20181109r6369-os4, and this still happens.
Managed to get some serial log of the crash, which is attached. Hope it helps.

comment:3 Changed 3 weeks ago by Thore Böckelmann

Component: undefinedString.mui
Milestone: future release5.0-2018R4
Owner: set to Thore Böckelmann
Priority: undecidednormal
Status: newassigned

comment:4 Changed 3 weeks ago by Thore Böckelmann

In 6372:

  • String.c: avoid calling GetRGB32() with invalid pen numbers. This refs #394.

comment:5 Changed 3 weeks ago by Thore Böckelmann

Please check again with the next nightly build (2018-11-27). I think the additional check fixes this issue.

comment:6 Changed 2 weeks ago by Thore Böckelmann

Any news here? Have you checked again with the latest nightly builds?

comment:7 Changed 2 weeks ago by walkero

I cannot reproduce the problem with the latest nightly build MUI-5.0-20181127r6374-os4.lha

comment:8 Changed 2 weeks ago by Thore Böckelmann

Resolution: fixed
Status: assignedclosed

Ok. I will close this ticket then as "fixed".

Note: See TracTickets for help on using tickets.