Opened 6 months ago

Closed 5 months ago

#382 closed task (invalid)

MUI version for 68k

Reported by: anonymous Owned by:
Priority: undecided Milestone: 5.0-2018R2
Component: undefined Version: 3.8
Severity: minor Keywords:
Cc: OS Platform: AmigaOS3
Blocked By: Blocking:
Release Notes:

Description

Phenomenon

I was looking for the MUI version to install to a A1200/030/128MB with AmigaOS 3.1.
I'm not sure which version of MUI should be installed: 3.8, 4.0 or 5.0.

Background analysis

Information about MUI

Implementation recommendation

I think some text about which Version is reccomendet for which system to be an important information.

Thanks for reading!!

Change History (3)

comment:1 Changed 6 months ago by Thore Böckelmann

Well, that depends on your hardware (CPU, graphic board, RAM) and what you want for yourself. MUI4 is nor or less obsolete and gives no advantage compared to MUI5.

MUI4/5 definitely demands more RAM and makes heavy use of graphical effects, like alpha shading. This requires a 24bit display. Although MUI4/5 still supports 8bit screenmodes with 256 colors at most the visual result will be inferior compared to a 24bit display. Even a 68030 CPU is not the best choice. 68040 or even 68060 would be better. MUI 3.8 used optimized (but non-portable and hard to maintain) Assembler code. All of this has been replaced by C code, because initially MUI4/5 was intended to run on PPC platforms only.

To sum it up: it is your choice what suits you best. Install MUI5 and try it. If you think it is ok for you, then keep it. Otherwise install MUI 3.8 and stick with it. MUI 3.8 definitely is faster on old hardware, but is has certain bugs which will never be fixed.

comment:2 Changed 6 months ago by Thore Böckelmann

Status: newpending

comment:3 Changed 5 months ago by Thore Böckelmann

Milestone: future release5.0-2018R2
Resolution: invalid
Status: pendingclosed

No reply within several weeks. Closing this one.

Note: See TracTickets for help on using tickets.