Opened 6 months ago

Closed 6 months ago

#378 closed bug (invalid)

AboutBox changes in r6280

Reported by: Samir Hawamdeh Owned by:
Priority: normal Milestone: 5.0-2018R2
Component: Aboutbox.mcc Version: 5.0-nightly build
Severity: minor Keywords:
Cc: OS Platform: AmigaOS4
Blocked By: Blocking:
Release Notes:

Description

Recent relayouting done in r6280 (Aboutbox.c) give graphical glitch when resizing thw window … as soon as you try minimize the window the bottom border will visually disappear .. but it appear again once you release the mouse button …

No problem with the previous version, maybe you can revert back or just found another solution to optimize it ? :-)

Attachments (1)

output.mkv (2.2 MB) - added by Samir Hawamdeh 6 months ago.

Change History (4)

comment:1 Changed 6 months ago by Thore Böckelmann

Milestone: future release5.0-2018R2
Priority: undecidednormal
Status: newaccepted

I cannot reproduce this issue, neither on AmigaOS4 nor on AmigaOS3. Which parts of the GUI exactly are disappearing? Perhaps you can provide a small video.

comment:2 Changed 6 months ago by Samir Hawamdeh

Sure, attached a small video done with SRec

Changed 6 months ago by Samir Hawamdeh

Attachment: output.mkv added

comment:3 Changed 6 months ago by Thore Böckelmann

Resolution: invalid
Status: acceptedclosed

You are mixing up classes. Aboutbox.mcc is what you get when you try the Aboutbox demo. What you are referring to is MUI's own About window (Aboutmui.mui with an embedded instance of Aboutpage.mui), which is something completely different and has not been touch recently, except the bumped copyright year a few weeks ago.

Aboutpage.mui makes heavy use of double buffering due to the usage of transparency effects for the images to reduce flickering while resizing the GUI. This combination takes its time to render.

Note: See TracTickets for help on using tickets.