Opened 7 months ago

Closed 7 months ago

Last modified 7 months ago

#377 closed bug (fixed)

Marking text in YAM read/write message window/panel not working

Reported by: Javier de las Rivas Owned by: Thore Böckelmann
Priority: normal Milestone: 5.0-2018R2
Component: Window.mui Version: 5.0-nightly build
Severity: minor Keywords:
Cc: OS Platform: All
Blocked By: Blocking:
Release Notes:

Description

Summary

When trying to mark some text in YAM2.10dev in the message read window/panel, it seems to don't "stop"/detach when you release LMB.

Steps to reproduce

  1. Open YAM and in the message read panel/window.
  2. LMB to mark a part of text, release LBM but doesn't work

Expected results

When releasing LBM marked text should stop/"cancel".

Actual results

marking text still goes and deosnt stops/"cancel".

Regression

Notes

Tested with MUI5 2018R1 and no problems.

Change History (3)

comment:1 Changed 7 months ago by Thore Böckelmann

Component: muimaster.libraryWindow.mui
Milestone: future release5.0-2018R2
OS Platform: undefinedAll
Owner: set to Thore Böckelmann
Priority: undecidednormal
Status: newassigned

comment:2 Changed 7 months ago by Thore Böckelmann

Resolution: fixed
Status: assignedclosed

In 6260:

  • Window.c: reverted the changes to the eventhandler sorting algorithm. The window's active and default objects can install more than one eventhandler which got lost by the changed approach. This closes #376 and closes #377.

comment:3 Changed 7 months ago by Javier de las Rivas

Tested with latest nightly build r6261 and works again as expected. THX

Note: See TracTickets for help on using tickets.