Opened 2 years ago

Closed 20 months ago

Last modified 4 months ago

#374 closed enhancement (fixed)

Support for AISS images in menu

Reported by: Samir Hawamdeh Owned by: Thore Böckelmann
Priority: normal Milestone: 5.0-2018R4
Component: Popmenu.mui Version: 5.0-nightly build
Severity: minor Keywords:
Cc: OS Platform: All
Blocked By: Blocking:
Release Notes:

Description

Analysis

Since the release of OS 4.1 Final Edition is become possible to use small AISS images for menus, i think it would be nice to implement such thing also in MUI

Enhancement recommendation

Many programs in Enancher Packages introduced that feature recently, and they are adapted to use 24*24 icon size by default, but with a simple env var they could be also resized at 16x16

An example of how it works could be found in latest Mixer 1.42 source:

http://openamiga.org/attachment/project/62/mixer142.lha

Here Javier implemented also a graphical option in Mixer's Prefs in order turn on/off the images and even to choose their size

Attachments (3)

Clock_16x16.jpg (83.7 KB) - added by Samir Hawamdeh 2 years ago.
Icon example in real life
24_24_icons_size.jpg (309.7 KB) - added by Samir Hawamdeh 4 months ago.
Popmenu_debug.lha (135.2 KB) - added by Thore Böckelmann 4 months ago.
Debug version of Popmenu.mui

Download all attachments as: .zip

Change History (9)

Changed 2 years ago by Samir Hawamdeh

Attachment: Clock_16x16.jpg added

Icon example in real life

comment:1 Changed 2 years ago by Thore Böckelmann

Take a look at the Menuimages demo. In principle everything you ask for is possible since more than 3(!) years by now already.

comment:2 Changed 20 months ago by Thore Böckelmann

Component: undefinedPopmenu.mui
Milestone: future release5.0-2018R4
OS Platform: AmigaOS4All
Owner: set to Thore Böckelmann
Priority: undecidednormal
Status: newassigned

comment:3 Changed 20 months ago by Thore Böckelmann

Resolution: fixed
Status: assignedclosed

In 6379:

  • Menuitem.c, Popmenu.c, misc: added the new attribute MUIA_Menuitem_AISSName. If specified the given AISS image will be placed in front of the menu item's text. This feature is completely user configurable and does NOT require AISS to be installed at all. If anything fails or is disabled the images will simply not be displayed. This finally closes #371 and closes #374.

comment:4 Changed 4 months ago by Samir Hawamdeh

Apparently we have a regression here …
it's very hard to track down exactly how to reproduce it, but sometimes (at random?) the AISS icons will turn back automatically to 24*24 size, even if default general settings, and even per application settings was set to use 16*16 as default

As usual a good test case is Odyssey. right click into the url area can show the issue, see grab

I don't know if the same issue could be reproduced also with other MUI's applications, even because in contrast to other programs, the action to open a menu is very frequently with applications such a web browser

Probably there is a little bug somewhere that for some reason will revert back the default size of the AISS icon to 24*24

Changed 4 months ago by Samir Hawamdeh

Attachment: 24_24_icons_size.jpg added

comment:5 Changed 4 months ago by Thore Böckelmann

If the icon size is reset to 24 then this means that MUI's internal configuration has most probably been trashed. Popmenu class just checks the value in MUI's configuration to be one of 3 definitions. If none of these 3 possibilities matches it falls back to 24x24 pixels. But this can only happen if someone trashes memory.

Unfortunately Odyssey is one very well known application to do this…

Changed 4 months ago by Thore Böckelmann

Attachment: Popmenu_debug.lha added

Debug version of Popmenu.mui

comment:6 Changed 4 months ago by Thore Böckelmann

You can try the debug version of Popmenu.mui. It will print out a warning in case of an invalid icon size setting. Valid values range from 0 to 3, any other value will let Popmenu class fall back to setting 3 (24px).

Note: See TracTickets for help on using tickets.