Opened 10 months ago

Closed 10 months ago

Last modified 10 months ago

#369 closed bug (invalid)

r6168 nightly build muimaster_lib 3.6MB!!!

Reported by: Javier de las Rivas Owned by:
Priority: normal Milestone: 5.0-2018R1
Component: muimaster.library Version: 5.0-nightly build
Severity: minor Keywords:
Cc: OS Platform: AmigaOS4
Blocked By: Blocking:
Release Notes:

Description

Summary

Ussualy muimaster_lib size is under 1MB, but on latest nightly build is 3.6MB!!!!

muimaster.library 3346160 ——rwed Hoy 01:01:48

#version muimaster.library file full
muimaster.library 21.113 (10-01-2018)
Copyright © 2006-2018 Thore Boeckelmann, Jens Maus [AmigaOS4/PPC] [svn r6168] [nightly]

Steps to reproduce

  1. Unpack MUI-5.0-20180113r6168-os4.lha 2.

Expected results

Actual results

Regression

Notes

Change History (2)

comment:1 Changed 10 months ago by Thore Böckelmann

Milestone: future release5.0-2018R1
Priority: undecidednormal
Resolution: invalid
Status: newclosed

The size is is intentional and all libraries and classes of the nightly builds have always been that big.

The reason is that the nightly build is a "debug" build. That means that the binaries contain debug information. Don't confuse this with the debug version of muimaster.library which spills out lots of debugging information during runtime. A debug build is exactly the same code as a release build, it just contains additional information which come to use in case of a crash. The crashlog of a debug build will contain plain text file names and line numbers, while the crashlog of a release build contains offsets only which must be translated to file name + line number by the developer with special tools. Thus it is much easier to spot the location of a crash much easier with a debug build than with a release build.

To sum it up: no need to worry.

comment:2 Changed 10 months ago by Javier de las Rivas

Oops, yes you're right I just mixed public releases with nightly builds :-/

Note: See TracTickets for help on using tickets.