Opened 6 months ago

Closed 6 months ago

Last modified 2 weeks ago

#347 closed bug (fixed)

Crash bug due to recent Listtree changes

Reported by: Oliver Roberts Owned by: Thore Böckelmann
Priority: undecided Milestone: 5.0-2017R2
Component: Listtree.mcc Version: 5.0-nightly build
Severity: minor Keywords:
Cc: OS Platform: AmigaOS4
Blocked By: Blocking:
Release Notes:

Description

Summary

There seems to be a bug in the Listtree.mcc changes that you made regarding fixing the width to the longest tree item. It is causing IBrowse's hotlist manager window to crash if groups have been used in the hotlist.

It crashes with 21.14, but not 21.12. As it freezes the system on my A1XE, I can't get at the crashlog - maybe you can? I can send any relevant IBrowse code to you that the crashlog points to, if required. Occurs with IBrowse 2.4 and 2.5.

Steps to reproduce

If your hotlist has groups in it, it will crash when opening. If not, the best way to reproduce is to start with an empty hotlist and then click the "Add group" button which triggers an instant crash/freeze.

Change History (4)

comment:1 Changed 6 months ago by Thore Böckelmann

Is IBrowse using a mixture of NList.mcc and Listtree.mcc for the hotlist window? I am just asking because the stacktrace recorded by WinUAE mentions both classes.

comment:2 Changed 6 months ago by Thore Böckelmann

Owner: set to Thore Böckelmann
Resolution: fixed
Status: newclosed

In 5954:

  • mcc/Listtree.c: fixed the possible endless loop and NULL pointer access caused by IBrowse's hotlist manager. This closes #347.

comment:3 in reply to:  1 Changed 6 months ago by Oliver Roberts

Replying to Thore Böckelmann:

Is IBrowse using a mixture of NList.mcc and Listtree.mcc for the hotlist window? I am just asking because the stacktrace recorded by WinUAE mentions both classes.

I don't believe so, no. There is no mention of NList in the hotlist window sources and of the related classes.

comment:4 Changed 2 weeks ago by Thore Böckelmann

Milestone: future release5.0-2017R2
Note: See TracTickets for help on using tickets.