Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#346 closed bug (invalid)

Odyssey: MUI crash with a Google Map

Reported by: Hubert Maier Owned by:
Priority: normal Milestone: 5.0-2017R2
Component: foreign application Version: 5.0-2017R1
Severity: minor Keywords:
Cc: OS Platform: AmigaOS4
Blocked By: Blocking:
Release Notes:

Description

Summary

Playing around with a small embedded Google Maps i can make MUI crash.

Steps to reproduce

  1. Go here: http://www.zimmerei-bachmayer.de/kontakt.htm (maybe other maps will "work" too)
  2. Resize, drag, move around, do whatever you like, sooner or later Odyssey will crash in MUI's "Drag" function, pulling down graphics.library with it

Expected results

No crash

Actual results

Crash

Regression

Not sure, i'd say no, because it didn't crash before, but who knows?

Notes

Attachments (1)

Crashlog_Odyssey_2017-04-12_09-53-12.txt (39.4 KB) - added by Hubert Maier 2 years ago.
Crashlog

Download all attachments as: .zip

Change History (3)

Changed 2 years ago by Hubert Maier

Crashlog

comment:1 Changed 2 years ago by Thore Böckelmann

Component: undefinedforeign application
Milestone: future release5.0-2017R2
Priority: undecidednormal
Resolution: invalid
Status: newclosed

I am affraid I cannot do anything here.

First of all, it is not MUI that is crashing, but Odyssey. Of course certain methods and functions of muimaster.library are mentioned in the crashlog, but in the end it is code of Odyssey which produces the fault.

The real bad thing happens in Odyssey's owbbrowser class, and there in the MUIM_CreateDragImage method. It obtains the dimensions of the area to create the drag image for, allocates a bitmap and uses the returned pointer without further checks. Most probably the AllocBitMap() call fails and returns NULL. Eventually Odyssey tries to WritePixelArray() the source image to the (non-)allocated bitmap and hence causes the crash due to the unchecked NULL-bitmap.

comment:2 Changed 2 years ago by Hubert Maier

Ah, ok, sorry for the hassle

Note: See TracTickets for help on using tickets.