#344 closed bug (invalid)

Cursor keys and ESC don't work when editing listview item and listview is in focus

Reported by: Andreas Falkenhahn Owned by:
Priority: normal Milestone: 5.0-2017R2
Component: List.mui Version: 5.0-2016R2
Severity: minor Keywords:
Cc: OS Platform: All
Blocked By: Blocking:
Release Notes:


I'm attaching a demo program for OS3. On MorphOS it's working correctly, but not on OS4 or OS3.

To reproduce:

  • make window large enough
  • click listview to make it take the focus
  • press return
  • try to edit the column item

You can add characters but cursor keys, edit keys, esc key are not working.

If the focus is not on the listview when pressing return or start editing
by mouse then all keys are working.

Attachments (1)

bugtest.lha (1.4 MB) - added by Andreas Falkenhahn 12 months ago.

Download all attachments as: .zip

Change History (4)

Changed 12 months ago by Andreas Falkenhahn

Attachment: bugtest.lha added

comment:1 Changed 12 months ago by Thore Böckelmann

No problem here on WinUAE. I can edit the item, move the cursor. Pressing ESC terminates the edit action. It doesn't matter whether the list is active or not.

However, pressing RETURN will no terminate the edit action but start it over and over again. I would expect RETURN to finish the input while ESC should act as a kind of "revert to the state before the edit action". But that might be a philosophic discussion.

I guess this is an Hollywood application. Can you reproduce this issue with a plain C application?

comment:2 Changed 12 months ago by Andreas Falkenhahn

I've now tested the latest nightly build and indeed the issue is gone. I was using a MUI version which was a few months old so it seems to have been fixed in the meanwhile.

comment:3 Changed 12 months ago by Thore Böckelmann

Component: Listview.muiList.mui
Milestone: future release5.0-2017R2
Priority: undecidednormal
Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.