Opened 20 months ago

Closed 19 months ago

Last modified 19 months ago

#332 closed bug (worksforme)

MUI5 and Apdf

Reported by: Russell Butler Owned by:
Priority: undecided Milestone: 5.0-2017R2
Component: undefined Version: 5.0-2017R1
Severity: minor Keywords:
Cc: OS Platform: AmigaOS3
Blocked By: Blocking:
Release Notes:

Description

Load Apdf, ok. Then load a pdf file. File loads then Apdf freezes.
The Amiga still works, other programs load and run but eventually, the system will lock up. Whilst Apdf is frozen, another file can be loaded but then the system reboots.

Apdf uses:

mui/Poppen.mui
muimaster.library
mui/Pendisplay.mui
mui/String.mui
mui/Title.mui
LIBS:mui/Title.mui
mui/Popasl.mui

Apdf works fine when I ahve MUI3.8 running

Using A1200 with Blizzard 060 and 400mb RAM

Change History (10)

comment:1 Changed 20 months ago by Thore Böckelmann

I have absolutely no problems with Apdf 2.2 in my WinUAE system. The included Test.pdf is shown as expected, as well as any other PDF file, except those that are not supported by that old xpdf basis. But there are neither freezes nor crashes. Some more detailed information from you would be really good.

comment:2 Changed 20 months ago by Thore Böckelmann

I just noticed you mention Title.mui twice but with different paths. Please make sure that NO MUI class ends up in LIBS:mui. MUI:Libs/mui is the one and only path where MUI classes should be installed to. Otherwise you might cause unpredictable results, because the most current version in MUI:Libs/mui will never be used if the same class with a different version exists in another path as well.

comment:3 Changed 20 months ago by Russell Butler

I just checked and the MUI libs are all in one place.

I Apdf 2.2, using:

ApdfDecrypt_68k module
ApdfUnLZW68k module
Apdf_68060fpu module

Apdf loads the document, it just freezes the miggy during the display process.

Whast other details would you like?

comment:4 Changed 20 months ago by Thore Böckelmann

Does the freeze happen with any PDF document or with a specific document only?

Perhaps it might be a good idea to run the typical debugging tools like Enforcer or their 68060 specific counterparts like the tools from the MMULib package (http://aminet.net/util/libs/MMULib.lha).

Without details about the freeze from your side I am unable to look for anything specific, especially when Apdf runs perfectly without any problems for me. I use the 68030fpu module, instead of the 68060fpu module. But if that is why Apdf works for me, then this still rules out MUI.

I just noticed that I get MungWall hit when quitting Apdf, regardless of the loaded document. This hit is caused by Apdf alone, there is no trace of MUI in the stacktrace. But this is one more reason why Apdf itself might be guilty here. It definitely trashes memory. Unfortunately it is hard to say if at all and how this trashing affects other applications and the system itself.

comment:5 Changed 20 months ago by Russell Butler

This happens with all pdf files, not just a specific one.

Unfortunately, Enforcer doesn't work on my system, I have MMULib but just don't understand it :( If you can explain what to do, I'll happily do it.

Thanks

Last edited 20 months ago by Russell Butler (previous) (diff)

comment:6 Changed 20 months ago by Thore Böckelmann

Basically running MuForce as replacement for Enforcer should be enough. As a first try you could run it from Workbench. Perhaps you should adjust the tooltypes to write the log directly to a file (FILE=path/to/your/logfile). Note that this might cause an unvalidated disk upon the next reboot in case of a system freeze.

We'll have to see whether further options are required or not.

Perhaps you should read the MuForce documentation yourself about the available options. I admit there is lots of quite technical stuff in there, but the part about the options should be understandable. If you know how to run Enforcer you will find lots of stuff you already know.

comment:7 Changed 19 months ago by Thore Böckelmann

Any news on this issue?

comment:8 Changed 19 months ago by Russell Butler

I have been trying but I don`t understand these debugging tools.
However, I reverted back to MUI3.8 and removed apdf.config. Although the test doc loaded fine, I was unable to load the window inspector from MUI settings, I got a crash.
So it seems it may be apdf rather than MUI5.
I will keep testing but I think you can close this issue?

comment:9 Changed 19 months ago by Thore Böckelmann

Milestone: future release5.0-2017R2
Resolution: worksforme
Status: newclosed

comment:10 Changed 19 months ago by Russell Butler

@thore
As an update, I tested all apdf binaries from 030-060. None work with MUI5, although they do work with MUI8.
Apdf nofpu works with both MUI, so it must be due to something in the fpu part of apdf, I think?

Note: See TracTickets for help on using tickets.