Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#325 closed bug (duplicate)

MUI programs cause system lockup with MUI 5 and classes

Reported by: Russell Butler Owned by: Thore Böckelmann
Priority: normal Milestone: 5.0-2017R1
Component: build environment Version: 5.0-2016R3
Severity: minor Keywords:
Cc: Jens Maus OS Platform: AmigaOS3
Blocked By: Blocking:
Release Notes:

Description

I have downloaded the latest MUI 5(R3) into a new, separate directory, and use assigns to switch between MUI 5 and 3.8. MUI5 works fine on all the demos included (except embedded images - "z.library missing, could not create RawImage.mui). z.library is definitely in the directory. No system lockup.

However, trying to run YAM & IBrowse, they complain that several classes are missing: TheBar, TheBardirt, TheButton, Betterstring, NList, NListdiew, NFloattext, NListTree, NBalance, NBitmap.

I have all the latest versions of these in my MUI3.8 folder, so I have copied them across to the MUI5 folder and both programs run - for about a minute. Then, I get a complete system lockup.

Amiga A1200T, Blizzard 060, 400mb RAM

Change History (8)

comment:1 Changed 2 years ago by Thore Böckelmann

Cc: Jens Maus added
Component: undefinedbuild environment
Milestone: future release5.0-2017R1
Owner: set to Thore Böckelmann
Priority: undecidednormal
Status: newassigned

I found some issues with our build environment. Please refer to ticket #319 for a possibly fixed MUI version.

comment:2 Changed 2 years ago by Thore Böckelmann

In 5637:

  • include/inline/graphics.h: added the GCC inline header file from the previous tool chain. This one uses correct 32bit parameter types for certain functions. This closes #319 and refs #325.

comment:3 Changed 2 years ago by Thore Böckelmann

In 5639:

  • include/inline/graphics.h: removed the local copy again, because the tool chain of our build system now consists of a properly fixed version. This refs #319 and refs #325.

comment:4 Changed 2 years ago by Thore Böckelmann

Can anybody please confirm whether the current nightly builds are working or not?

comment:5 Changed 2 years ago by Russell Butler

Hi, sorry for the delay, emails went to my SPAM folder.
I can confirm that MUI5 & YAM now seem to work fine, though only used it for 30 minutes (which is 29 minutes longer than previously!)

However other programs (IBrowse, DrawStudio) work for a time and then lock up. IBrowse worked on several websites but when trying to close it down, I got Guru errors that I couldn`t get out of. DrawStudio just crashed the whole system.
Not sure if this is MUI5 or not, but I`ll carry on testing.

comment:6 Changed 2 years ago by Thore Böckelmann

Resolution: duplicate
Status: assignedclosed

comment:7 Changed 2 years ago by Russell Butler

Ok, I have spent all afternoon testing and am happy to report that Yam and IBrowse now seem to work fine. I still need to test some other programs that use mum but Voyager at least, is missing some classes, though it does list them I have left mui5 as the default now and will only switch back to 3.8 if I really have to.

comment:8 Changed 2 years ago by Thore Böckelmann

I think the initial reason of this ticket is fixed now. Please open a new one for further issues.

Note: See TracTickets for help on using tickets.