Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#322 closed bug (fixed)

Drag and Drop bug in Odyssey's Bookmark Manager

Reported by: Hubert Maier Owned by: Thore Böckelmann
Priority: normal Milestone: 5.0-2017R1
Component: Listtree.mcc Version: 5.0-2016R2
Severity: minor Keywords:
Cc: OS Platform: All
Blocked By: Blocking:
Release Notes:

Description

Summary

First of all, i'm not sure if this is Odyssey's fault or a bug in MUI.

In Odyssey's "Manage Bookmark" window one can drag and drop bookmarks around and they get automatically saved ot the bookmarks file.

There is an instance where one can erase a bookmark by accident by sending it into the void, which should not happen.

Steps to reproduce

1) Open Odyssey
2) Righ click to bring up the menu and choose the tab "Bookmarks"
3) Once there choose "Manage Bookmarks…"
4) Inside this window, if you have none, create some separators/links by using "Add Separator" (or add some links)
5) Now grab one separator/link and move it all the way up to your first entry right under "Title"
6) Move the saperator/link on the "line" underneath "Title" which separates the window elements

If you now move the separator/link to the right or left you will see the "dotted" line or lasso line come into view, which indicates where your separator/link will be placed.

7) Move the separator/link up so that i will be placed as *very first* entry in this list
8) Drop it and it will vanish

If it doesn't happen right away, try to cover the dotted line/lasso line with your dragged item completely so that it isn't visible and then drop your item.

Expected results

The dragged item should either be placed as entry number one on the very top of the list, like the dotted line/lasso line indicates or be dropped back to it's place where one picked it up.

Actual results

The entry is getting deleted, which is really bad.

Regression

I don't think so, i remember having this behaviour on older versions too, but was never able to reproduce it.

Notes

No idea what component i should blame it on.
Using the MUI settings from the Bookmark window tells me (or does it?) it's not using NListtree for the Bookmarks window, nonetheless it *seems" to be another part of MUI (as i believe the GUI of Odyssey is completely MUI?).

Please feel free to correct me.

AmigaOS4 FE Update 1

Attachments (2)

Listtree_21.5_debug.lha (159.7 KB) - added by Thore Böckelmann 3 years ago.
Listtree.mcc 21.5 debug version
Sashimi.OUT (91.0 KB) - added by Hubert Maier 3 years ago.
log with only one link available

Download all attachments as: .zip

Change History (12)

comment:1 Changed 3 years ago by Thore Böckelmann

So far I really have no clue what might be going wrong here or who may be at fault. Although Odyssey's bookmark listtree does some own stuff during DnD actions it is Listtree.mcc who does all the node rearrangements when the dragged node is dropped eventually.

Changed 3 years ago by Thore Böckelmann

Attachment: Listtree_21.5_debug.lha added

Listtree.mcc 21.5 debug version

comment:2 Changed 3 years ago by Thore Böckelmann

Please try the attached debug version of Listtree.mcc. You will need to remove the ".debug" extension.

Please type this in a Shell before you run Odyssey:

setenv muidebug list

Furthermore you must run Sashimi to capture the debug output. All details about a debug version like this can be found in the FAQ. Then do the usual steps to let the issue happen. Finally attach the captured log here. I will try to find out what is going wrong then.

Changed 3 years ago by Hubert Maier

Attachment: Sashimi.OUT added

log with only one link available

comment:3 Changed 3 years ago by Hubert Maier

First of all, thanks a lot for the quick response

installed the listtree.mcc (debug) - check
setenv muidebug list - check
sashimi > sashimi.out - check

I created a one line bookmark file so it doesn't get too big

Steps i did were:

1) Start Odyssey
2) Open up Bookmarks/Manage Bookmarks
3) Add Separator
4) D&D Separator from position 2 to position above the only link available, where it vanished into oblivion

log attached, hope it helps, if you need me more stuff to do, just shout

if you need me to attach a log with my huge bookmarks file, just shout (although it won't change a thing except the log being bigger)

EDIT: No memguard, i'm afraid…this program freezes my system on different occasions when running (need to write bug report to the os devs pronto)

Last edited 3 years ago by Hubert Maier (previous) (diff)

comment:4 Changed 3 years ago by Thore Böckelmann

Component: undefinedListtree.mcc
Milestone: future release5.0-2017R1
OS Platform: AmigaOS4All
Owner: set to Thore Böckelmann
Priority: undecidednormal
Status: newassigned

I just hacked up a small demo application and now I can confirm that the dragged node vanishes as soon as it is dropped to be moved above the first entry. So Listtree.mcc is the culprit here. I will investigate.

comment:5 Changed 3 years ago by Thore Böckelmann

In 5625:

  • mcc/Listtree.c: use the correct list when moving a treenode above the topmost treenode. This refs #322.

comment:6 Changed 3 years ago by Thore Böckelmann

The next nightly build should fix this issue. Please try it and report back.

comment:7 Changed 3 years ago by Hubert Maier

Awesome, thanks a lot

Where can i find the nightly builds of listtree.mcc?
Or do i have to install the whole MUI set?

comment:8 Changed 3 years ago by Thore Böckelmann

Listtree.mcc is contained in the normal nightly builds of MUI, just like anything else.

Although Listtree.mcc is the only modified component so far since the release of 5.0-2016R3 I recommend to not mix up stuff of the nightly builds with the official releases.

comment:9 Changed 3 years ago by Hubert Maier

Tested Nightly Build and working

Thanks a lot

comment:10 Changed 3 years ago by Thore Böckelmann

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.