Opened 3 years ago

Closed 2 years ago

#314 closed bug (fixed)

UTF8 locale problems on 68K builds

Reported by: Mikhail Malyshev Owned by: Thore Böckelmann
Priority: normal Milestone: 5.0-2017R1
Component: contributions Version: 5.0-nightly build
Severity: minor Keywords:
Cc: OS Platform: AmigaOS3
Blocked By: Blocking:
Release Notes:

Description

Summary

Newer catalogs for contribution classes are provided in UTF8
They do not work on classic systems

Regression

Classic system should get 8bit encoded catalogs (as before 2016), or classes need to play some trickery to convert the texts before rendering it.

Attachments (1)

mui5-os3-utf8-bug.png (185.6 KB) - added by Mikhail Malyshev 3 years ago.
Crippled UTF8 text

Download all attachments as: .zip

Change History (7)

Changed 3 years ago by Mikhail Malyshev

Attachment: mui5-os3-utf8-bug.png added

Crippled UTF8 text

comment:1 Changed 3 years ago by Thore Böckelmann

Component: undefinedforeign class
Milestone: future release5.0-2016R2
Priority: undecidednormal
Resolution: fixed
Status: newclosed

Unfortunately the catalogs were encoded as UTF8 instead of ISO-8859-x. This has been fixed already. Please use the catalogs from the previous release until the fixed versions are release.

This applies for all recently updated classes (BetterString, NList, TextEditor, TheBar, openurl.library).

comment:2 Changed 3 years ago by Mikhail Malyshev

Resolution: fixed
Status: closedreopened

Todays MUI-5.0-2016R2-os3-contrib still has UTF8 versions

comment:3 Changed 2 years ago by Thore Böckelmann

Milestone: 5.0-2016R2future release

No need to complain again for 5.0-2016R3. The catalogs are still unchanged, because no fixed versions of the contributed classes have been released yet.

comment:4 Changed 2 years ago by Thore Böckelmann

Component: foreign classcontributions

comment:5 Changed 2 years ago by Thore Böckelmann

Milestone: future release5.0-2017R1

comment:6 Changed 2 years ago by Thore Böckelmann

Owner: set to Thore Böckelmann
Resolution: fixed
Status: reopenedclosed

In 5727:

  • contrib_common/locale: regenerated all contributed catalogs with correct encoding, even if the corresponding classes have not been updated officially yet. This closes #314.
Note: See TracTickets for help on using tickets.