Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#309 closed bug (fixed)

Crash when updating BetterString

Reported by: Samir Hawamdeh Owned by:
Priority: normal Milestone: 4.0-2016R3
Component: Settings.mui Version: 4.0-nightly build
Severity: minor Keywords:
Cc: OS Platform: AmigaOS4
Blocked By: Blocking:
Release Notes:

Description

Summary

After i was updating the BetterString class (downloading and then copying manually the latest version in "MUI/Libs/mui" directory) i accidentally selected the class from the MUI prefs

I got a crash, see attach

(Crash happened using the latest MUI 4.0 nightly build under AmigaOS4)

Of course to handle this correctly a reboot was for sure a necessity, however it should not crash either i think (?)

Attachments (1)

Crashlog_MUI_2016-08-07_06-05-47.txt (34.1 KB) - added by Samir Hawamdeh 3 years ago.

Download all attachments as: .zip

Change History (12)

Changed 3 years ago by Samir Hawamdeh

comment:1 Changed 3 years ago by Thore Böckelmann

Did the crash happen by just going to BetterString's page? Or did you change any of BetterString's prefs?

comment:2 Changed 3 years ago by Samir Hawamdeh

Yes crash happened when i opened the BetterString prefs

And no, before overwriting the old version i didn't changed anything in BetterStrings preferences ..
Default configuration was set (and still set now with the latest version of the class)

comment:3 Changed 3 years ago by Thore Böckelmann

In 5513:

  • mastermisc.c: added some more debug output to the internal functions MUIP_Setup() and MUIP_AskMinMax() in case there is no valid render info structure. This refs #307 and refs #309.

comment:4 Changed 3 years ago by Thore Böckelmann

Please try to reproduce this issue with the next nightly build's debug version. I'd like to know whether there appears a line like "invalid MRI" in the debug output. There is no need to set ENV:muidebug to any special content.

comment:5 Changed 3 years ago by Thore Böckelmann

In 5515:

  • Settings.c: do an artifical MUIM_Setup before MUIM_AskMinMax to determine fixed height edit groups. Without the MUIM_Setup the MUIM_AskMinMax might do illegal memory accesses. This refs #307 and refs #309.

comment:6 Changed 3 years ago by Thore Böckelmann

I think I found the cause of the crash. However, if the next nightly build still crashes then please try the debug build of muimaster.library nevertheless.

comment:7 Changed 3 years ago by Samir Hawamdeh

Ok will test
Thank you Thore :-)

comment:8 Changed 3 years ago by Thore Böckelmann

Any news here? According to #307 this issue seems to be fixed.

comment:9 Changed 3 years ago by Samir Hawamdeh

Sorry i was busy.. I think you can close the ticket as i retried with the latest build and the crash seems gone :-)

Thanks !

comment:10 Changed 3 years ago by Thore Böckelmann

Component: undefinedSettings.mui
Milestone: future release4.0-2016R4
Priority: undecidednormal
Resolution: fixed
Status: newclosed

comment:11 Changed 3 years ago by Thore Böckelmann

Milestone: 4.0-2016R44.0-2016R3
Note: See TracTickets for help on using tickets.