Opened 3 years ago

Closed 3 years ago

#307 closed bug (fixed)

MUI5 GR with Odyssey v1.23

Reported by: kenwilde2@… Owned by:
Priority: normal Milestone: 5.0-2016R2
Component: Settings.mui Version: 5.0-2016R1
Severity: minor Keywords:
Cc: OS Platform: AmigaOS4
Blocked By: Blocking:
Release Notes:

Description

System X1000 with os4.1 up to date beta.
Opened MUI prefs, Windows tab to change fonts, GR on save, random crash, but WookieChat doesn't like the same libs that show in the stack trace.

Crash log for task "Odyssey"
Generated by GrimReaper 53.19
Crash occured in module Gauge.mui at address 0x7F9AD0C0
Type of crash: DSI (Data Storage Interrupt) exception
Alert number: 0x80000003

Register dump:
GPR (General Purpose Registers):

0: 7F9AD0B0 5AA75EA0 00000000 00000000 5A117368 5AA761C8 5AA761C8 00000000
8: 5A117390 00000000 00000000 02B20000 44822884 5ACA9960 5A6E2C9F 5D258950

16: 5AA76488 5A1176D8 00000004 000000E8 5A08C248 7F7AC8B0 5A1176D8 5AA76488
24: 5AA761C8 5B1FFAD0 5D3F0000 5A117368 5A117450 5AA761C8 5A117390 00000000

FPR (Floating Point Registers, NaN = Not a Number):

0: nan 2.19345e-05 0 0
4: 0 0 1 -5
8: -1436 4.5036e+15 1 0.431373

12: 0.435294 4.5036e+15 0 0
16: 0 0 0 0
20: 0 0 0 0
24: 0 0 0 0
28: 0 0 0 0

FPSCR (Floating Point Status and Control Register): 0xA6204100

SPRs (Special Purpose Registers):

Machine State (msr) : 0x0200B030

Condition (cr) : 0x5A4ED02C

Instruction Pointer (ip) : 0x7F9AD0C0

Xtended Exception (xer) : 0x472D5018

Count (ctr) : 0x6FF464D0

Link (lr) : 0x7FB8E600

DSI Status (dsisr) : 0x472D4DD0
Data Address (dar) : 0x02202E48

680x0 emulated registers:
DATA: 94605B00 00000000 00000000 00000000 00000000 00000000 00000000 00000000
ADDR: 6FFB8000 945FA500 00000000 00000000 00000000 00000000 00000000 5AA771F0
FPU0: 0 0 0 0
FPU4: 0 0 0 0

Symbol info:
Instruction pointer 0x7F9AD0C0 belongs to module "Gauge.mui" (PowerPC)
Symbol: Gauge_Dispatcher + 0x6C8 in section 1 offset 0x0000109C

Stack trace:

LIBS:mui/Gauge.mui:Gauge_Dispatcher()+0x6c8 (section 1 @ 0x109C)
LIBS:mui/Gauge.mui:Gauge_Dispatcher()+0x6b8 (section 1 @ 0x108C)
native kernel module intuition.library.kmod+0x000215ec
native kernel module intuition.library.kmod+0x0000a2ac
LIBS:mui/Settingsgroup.mui:FancyGauge_Dispatcher()+0xc8 (section 1 @ 0x72C)
native kernel module intuition.library.kmod+0x00021448
native kernel module intuition.library.kmod+0x000215ec
native kernel module intuition.library.kmod+0x0000a3f4
native kernel module intuition.library.kmod+0x0000a034
LIBS:muimaster.library:LIB_MUIP_AskMinMax()+0x40 (section 1 @ 0x132C4)
LIBS:muimaster.library:m_Group_AskMinMax()+0xc0 (section 1 @ 0x41214)
LIBS:muimaster.library:GroupDispatcher()+0x10b8 (section 1 @ 0x459EC)
native kernel module intuition.library.kmod+0x00021448
native kernel module intuition.library.kmod+0x000215ec
native kernel module intuition.library.kmod+0x0000a3f4
native kernel module intuition.library.kmod+0x0000a034
LIBS:muimaster.library:LIB_MUIP_AskMinMax()+0x40 (section 1 @ 0x132C4)
LIBS:muimaster.library:m_Group_AskMinMax()+0xc0 (section 1 @ 0x41214)
LIBS:muimaster.library:GroupDispatcher()+0x10b8 (section 1 @ 0x459EC)
native kernel module intuition.library.kmod+0x00021448
native kernel module intuition.library.kmod+0x000215ec
native kernel module intuition.library.kmod+0x0000a3f4
native kernel module intuition.library.kmod+0x0000a034
LIBS:muimaster.library:LIB_MUIP_AskMinMax()+0x40 (section 1 @ 0x132C4)
LIBS:muimaster.library:m_Group_AskMinMax()+0xc0 (section 1 @ 0x41214)
LIBS:muimaster.library:GroupDispatcher()+0x10b8 (section 1 @ 0x459EC)
native kernel module intuition.library.kmod+0x00021448
native kernel module intuition.library.kmod+0x000215ec
native kernel module intuition.library.kmod+0x0000a2ac
LIBS:muimaster.library:MccprefsDispatcher()+0x1c0 (section 1 @ 0x60058)
native kernel module intuition.library.kmod+0x00021448
native kernel module intuition.library.kmod+0x000215ec
native kernel module intuition.library.kmod+0x0000a2ac
native kernel module intuition.library.kmod+0x00021448
native kernel module intuition.library.kmod+0x000215ec
native kernel module intuition.library.kmod+0x0000a3f4
native kernel module intuition.library.kmod+0x0000a034
LIBS:muimaster.library:LIB_MUIP_AskMinMax()+0x40 (section 1 @ 0x132C4)
LIBS:muimaster.library:m_Group_AskMinMax()+0xc0 (section 1 @ 0x41214)
LIBS:muimaster.library:GroupDispatcher()+0x10b8 (section 1 @ 0x459EC)
native kernel module intuition.library.kmod+0x00021448
native kernel module intuition.library.kmod+0x000215ec
native kernel module intuition.library.kmod+0x0000a3f4
native kernel module intuition.library.kmod+0x0000a034
LIBS:muimaster.library:LIB_MUIP_AskMinMax()+0x40 (section 1 @ 0x132C4)
LIBS:muimaster.library:m_Group_AskMinMax()+0xc0 (section 1 @ 0x41214)
LIBS:muimaster.library:GroupDispatcher()+0x10b8 (section 1 @ 0x459EC)
native kernel module intuition.library.kmod+0x00021448
native kernel module intuition.library.kmod+0x000215ec
native kernel module intuition.library.kmod+0x0000a3f4
native kernel module intuition.library.kmod+0x0000a034
LIBS:muimaster.library:LIB_MUIP_AskMinMax()+0x40 (section 1 @ 0x132C4)
LIBS:muimaster.library:m_Group_AskMinMax()+0xc0 (section 1 @ 0x41214)
LIBS:muimaster.library:GroupDispatcher()+0x10b8 (section 1 @ 0x459EC)
native kernel module intuition.library.kmod+0x00021448
native kernel module intuition.library.kmod+0x000215ec
native kernel module intuition.library.kmod+0x0000a3f4
native kernel module intuition.library.kmod+0x0000a034
LIBS:muimaster.library:LIB_MUIP_AskMinMax()+0x40 (section 1 @ 0x132C4)
LIBS:mui/Settings.mui:Settings_Dispatcher()+0x1278 (section 1 @ 0x5490)
native kernel module intuition.library.kmod+0x00021448
native kernel module intuition.library.kmod+0x000215ec
native kernel module intuition.library.kmod+0x0000a3f4
native kernel module intuition.library.kmod+0x0000a034
LIBS:mui/Settings.mui:Settings_Dispatcher()+0x1aa8 (section 1 @ 0x5CC0)
native kernel module intuition.library.kmod+0x00021448
native kernel module intuition.library.kmod+0x000215ec
native kernel module intuition.library.kmod+0x0000a3f4
native kernel module intuition.library.kmod+0x0000a034
LIBS:muimaster.library:LIB_MUIP_Setup()+0x40 (section 1 @ 0x12F38)
LIBS:muimaster.library:GroupDispatcher()+0x4d4 (section 1 @ 0x44E08)
native kernel module intuition.library.kmod+0x00021448
native kernel module intuition.library.kmod+0x000215ec
native kernel module intuition.library.kmod+0x0000a2ac
native kernel module intuition.library.kmod+0x00021448
native kernel module intuition.library.kmod+0x000215ec
native kernel module intuition.library.kmod+0x0000a3f4
native kernel module intuition.library.kmod+0x0000a034
LIBS:muimaster.library:LIB_MUIP_Setup()+0x40 (section 1 @ 0x12F38)
LIBS:muimaster.library:OpenTheWindow()+0x22c (section 1 @ 0x81CDC)
LIBS:muimaster.library:m_Window_SET()+0x152c (section 1 @ 0x84800)
LIBS:muimaster.library:WindowDispatcher()+0x8d4 (section 1 @ 0x85C44)
native kernel module intuition.library.kmod+0x00021448
native kernel module intuition.library.kmod+0x000215ec
native kernel module intuition.library.kmod+0x000218c8
native kernel module intuition.library.kmod+0x00009ee4
native kernel module intuition.library.kmod+0x0000a184
LIBS:muimaster.library:ApplicationDispatcher()+0x1420 (section 1 @ 0x2CAB0)
native kernel module intuition.library.kmod+0x00021448
native kernel module intuition.library.kmod+0x000215ec
native kernel module intuition.library.kmod+0x0000a2ac
Odyssey:_ZL8dispatchP6IClassPmP4_Msg()+0x164 (section 1 @ 0xF604)
native kernel module intuition.library.kmod+0x00021448
native kernel module intuition.library.kmod+0x000215ec
native kernel module intuition.library.kmod+0x0000a3f4
LIBS:muimaster.library:m_Application_NewInput()+0xc28 (section 1 @ 0x289A8)
LIBS:muimaster.library:ApplicationDispatcher()+0x18d4 (section 1 @ 0x2CF64)
native kernel module intuition.library.kmod+0x00021448
native kernel module intuition.library.kmod+0x000215ec
native kernel module intuition.library.kmod+0x0000a2ac
Odyssey:_ZL8dispatchP6IClassPmP4_Msg()+0x164 (section 1 @ 0xF604)
native kernel module intuition.library.kmod+0x00021448
native kernel module intuition.library.kmod+0x000215ec
native kernel module intuition.library.kmod+0x0000a3f4
native kernel module intuition.library.kmod+0x0000a034
Odyssey:_Z9main_loopv()+0x16c (section 1 @ 0x758)
Odyssey:main()+0x1a4 (section 1 @ 0x1414)
native kernel module newlib.library.kmod+0x000020a4
native kernel module newlib.library.kmod+0x00002d54
native kernel module newlib.library.kmod+0x00002ee8
Odyssey:_start()+0x170 (section 1 @ 0x16C)
native kernel module dos.library.kmod+0x00026180
native kernel module kernel+0x00041a9c
native kernel module kernel+0x00041ae4

PPC disassembly:

7f9ad0b8: 7c7f1b78 mr r31,r3
7f9ad0bc: a15e0000 lhz r10,0(r30)

*7f9ad0c0: 80890008 lwz r4,8(r9)

7f9ad0c4: 8129000c lwz r9,12(r9)
7f9ad0c8: 7c845214 add r4,r4,r10

System information:

CPU

Model: P.A. Semi PWRficient PA6T-1682M VB1
CPU speed: 1800 MHz
FSB speed: 900 MHz
Extensions: altivec

Machine

Machine name: AmigaOne X1000
Memory: 2097152 KB
Extensions: bus.pci bus.pcie
1.
2.

Expected results

Actual results

Regression

Notes

Change History (8)

comment:1 Changed 3 years ago by Thore Böckelmann

Does the crash happen in WookieChat or Odyssey? You are talking about WookieChat, but the crashlog definitely points to Odyssey.

And please provide the crashlog as attachment next time instead of inlining it into the bug report's main text. That makes reading a lot easier.

comment:2 Changed 3 years ago by Thore Böckelmann

If this crash is really about Odyssey, does it happen with other applications as well? Odyssey is known to trash memory, even the most recent version which is supposed to fix certain memory issues.

comment:3 Changed 3 years ago by Thore Böckelmann

In 5513:

  • mastermisc.c: added some more debug output to the internal functions MUIP_Setup() and MUIP_AskMinMax() in case there is no valid render info structure. This refs #307 and refs #309.

comment:4 Changed 3 years ago by Thore Böckelmann

Please try to reproduce this issue with the next nightly build's debug version. I'd like to know whether there appears a line like "invalid MRI" in the debug output. There is no need to set ENV:muidebug to any special content.

comment:5 Changed 3 years ago by Thore Böckelmann

In 5515:

  • Settings.c: do an artifical MUIM_Setup before MUIM_AskMinMax to determine fixed height edit groups. Without the MUIM_Setup the MUIM_AskMinMax might do illegal memory accesses. This refs #307 and refs #309.

comment:6 Changed 3 years ago by Thore Böckelmann

I think I found the cause of the crash. However, if the next nightly build still crashes then please try the debug build of muimaster.library nevertheless.

comment:7 Changed 3 years ago by Ken Wilde

I grabbed & installed the Sept 8th nightly build. Both Odyssey on the x1000 & WookieChat on the SAM440 no longer crash when changing the font size.

comment:8 Changed 3 years ago by Thore Böckelmann

Component: Gauge.muiSettings.mui
Milestone: future release5.0-2016R2
Priority: undecidednormal
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.