Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#289 closed bug (fixed)

Crash while closing tabs in Odyssey 1.23

Reported by: Samir Hawamdeh Owned by: Thore Böckelmann
Priority: normal Milestone: 4.0-2016R1
Component: Group.mui Version: 4.0-nightly build
Severity: minor Keywords:
Cc: OS Platform: AmigaOS4
Blocked By: Blocking:
Release Notes:

Setting the active page of a paged group does the graphical update only if the group is not currently in "change mode" initiated by the MUIM_Group_InitChange method.

Description

A rare crash sometimes occurred while i browse the web with Odyssey 1.23, in this case i was able to reproduce it by having many tabs opened (each tab had an image loaded) and then starting closing them one by one

I got a skippable DSI that apparently point to the Group.c function

I'm using the latest MUI4 nightly (svn r5155)

Attachments (3)

Crashlog_Odyssey_2016-01-22_09-04-00.txt (32.4 KB) - added by Samir Hawamdeh 3 years ago.
crash.png (54.5 KB) - added by Samir Hawamdeh 3 years ago.
MUI-4.0-20160122r5155-os4.lha (3.7 MB) - added by Thore Böckelmann 3 years ago.
MUI 4.0 r5155 with different MUIA_Group_ActivePage handling

Change History (11)

Changed 3 years ago by Samir Hawamdeh

Changed 3 years ago by Samir Hawamdeh

Attachment: crash.png added

comment:1 Changed 3 years ago by Thore Böckelmann

Milestone: future release4.0-2016R1
Owner: set to Thore Böckelmann
Priority: undecidednormal
Status: newassigned

I just have a very vague idea what might be causing this. Please try the attached r5155 version which does some more checks when modifying the active page of a paged group.

Changed 3 years ago by Thore Böckelmann

MUI 4.0 r5155 with different MUIA_Group_ActivePage handling

comment:2 Changed 3 years ago by Samir Hawamdeh

Ok will test it, however consider that this crash is really hard to reproduce (as it happen rarely) so even if someday i will be able to (re)encounter a similar situation in end i will never be sure if i can reproduce it again or not…

Can say that this report is a bit particular, particular because i noted this crash long ago, however at the time i completely forgot to save the log, so i decided to wait again for it before opening a ticket :-)

So if you are changed somethings probably i will never be able to reproduce it again … (aka high probability that the change you did fixed my problem already)

At this point i have a suggest: why don't include this fix already in the next nightly ?
Meantime i can continue my normal usage and i can even continue to update my system when a new nightly will be released, then eventually if the same crash happen again you can always revert back (or try to fix it in another way …)

What do you think ?

comment:3 Changed 3 years ago by Thore Böckelmann

May it's worth a try… At least the change doesn't seems to cause any severe effects on the first sight.

comment:4 Changed 3 years ago by Thore Böckelmann

In 5162:

  • Group.c: setting the active page of a paged group does the graphical update only if the group is not currently in "change mode" initiated by the MUIM_Group_InitChange method. This refs #289.

comment:5 Changed 3 years ago by Thore Böckelmann

In 5167:

  • Group.c: converted the change state check into a separate function to make it more convenient to use. This function checks the object and its parent object to an active change state. This refs #289.

comment:6 Changed 3 years ago by Thore Böckelmann

Resolution: fixed
Status: assignedclosed

I think the active change state while setting a new active page really was the culprit for the crash. At least the crash log definitely points to that location on its way to the final crash. Hence I'd say this bug is fixed now. If this crash - or a similar one - should happen again please reopen this ticket.

comment:7 Changed 3 years ago by Samir Hawamdeh

@Thore

Indeed in latest days i'm still used the r5155 and i wasn't able to replicate the issue anymore, probably you fixed the issue in that version …
Of course I will continue my test and eventually i will reopen the ticket.

Good job mate ;-)

comment:8 Changed 3 years ago by Thore Böckelmann

Release Notes: modified (diff)
Note: See TracTickets for help on using tickets.