Opened 6 years ago

Closed 6 years ago

Last modified 5 years ago

#28 closed bug (fixed)

DSI crash on newlib.library.kmod

Reported by: Samir Hawamdeh Owned by:
Priority: normal Milestone: 4.0-2014R4
Component: foreign class Version: 4.0-2014R3
Severity: minor Keywords:
Cc: OS Platform: AmigaOS4
Blocked By: Blocking:
Release Notes:

Description

Summary

I need to test it further because i'm not 100% sure if it's a real issue or not, however at the end i though it's better to open it as a ticket so maybe you can help me to understand..

Don't know if the same happen also in latest MUI4 R3 release, right now I'm using an interim version of muimaster.library (version 20.6185)

When i open the MUI prefs (from SabreMSN) to change the TheBar behaviour I got a skippable crash that point to newlib.library.kmod

It happen also in other applications, but when i select other classes instead

Steps to reproduce

  1. Open MUI prefs from a MUI application (For example SabreMSN)
  2. Select a MUI class (for example TheBar, NList etc)

See crashlogs attached

Attachments (3)

Crashlog_SabreMSN_2014-05-02_04-32-30.txt (32.6 KB) - added by Samir Hawamdeh 6 years ago.
Crashlog_MUI_2014-05-02_04-29-42.txt (32.0 KB) - added by Samir Hawamdeh 6 years ago.
te_mcp_15_46_20140503.lha (34.0 KB) - added by Thore Böckelmann 6 years ago.
TextEditor.mcp 15.46 prerelease 2014-05-03

Download all attachments as: .zip

Change History (7)

Changed 6 years ago by Samir Hawamdeh

Changed 6 years ago by Samir Hawamdeh

comment:1 Changed 6 years ago by Thore Böckelmann

Component: undefinedforeign class
Priority: undecidednormal

According to the crashlog TextEditor.mcp is the only possible candidate for the crash due to the function name.

Changed 6 years ago by Thore Böckelmann

Attachment: te_mcp_15_46_20140503.lha added

TextEditor.mcp 15.46 prerelease 2014-05-03

comment:2 Changed 6 years ago by Thore Böckelmann

Milestone: MUI 4.0-2014R4
Resolution: fixed
Status: newclosed

Please try again with the new TextEditor.mcp. This should fix this issue.

comment:3 Changed 6 years ago by Samir Hawamdeh

Yep it does, thank you ;-)

comment:4 Changed 5 years ago by Thore Böckelmann

Milestone: MUI 4.0-2014R44.0-2014R4

Milestone renamed

Note: See TracTickets for help on using tickets.